0

I recently upgraded all the packages on my Cygwin (x64) install and since then, my VIM shows "m" at the start of some lines and around whitespace. (My guess is that it might be in places where escape codes are present for syntax highlighting)

(Googling for the issue seems impossible)

Sample file: (Showing that it is not a \r\n issue...)

gert@local ~ $file .vimrc;cat -A .vimrc
.vimrc: ASCII text
set mouse=$

Vim view:

mset mmouse=
m~                                                                                                  ~
~
~
~
".vimrc" 1L, 11C                              1,1           All

Other info:

  • mintty is used (Cygwin default?)
  • TERM and mintty's setting is set to "xterm-256color"
  • The "m" characters also appear around editing
  • set syntax= seems to help (Things like searches still have issues)
  • VIM 8.0
  • Cygwin version: 2.8.0(0.309/5/3)

Is there a way to get VIM back in a usable state, with colours.

This is in one of the vimrc files: (Possibly via this)

" Settings to try and get syntax working
set nocompatible
set nocp
set backspace=indent,eol,start
set term=xterm-256
set hlsearch
set t_Co=8
set t_Sb=m
set t_Sf=m

Removing the "t_Sb" and "t_Sf" settings gets rid of the "m"s but colours fails to work as well...

  • Plain vi mode is usable... (Even things like colour errors) I'm quite sure this is escape code related... – Gert van den Berg Jun 21 '17 at 11:11
0

Removing these lines from the vimrc fixes it:

set t_Co=8
set t_Sb=m
set t_Sf=m
set term=xterm-256

(There might be other things in my /etc.vimrc as well, but this works for me...)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.