my hostname is newton ...when I set " Newton" in /etc/hosts .. parallels stops working.. when I set " localhost" in /etc/hosts apache installed via ports stops working.. when I add both '" localhost", and " newton" to hosts file.. parallels network doesnt work


3 Answers 3


I'd say, this is not generally wrong. You definitely should leave the first few lines in your /etc/hosts file:       localhost broadcasthost
::1             localhost 
fe80::1%lo0     localhost
# Add additional host names below: newton testhost something

I've got such a configuration myself on Mac OS 10.6 (Snow Leopard) and had this on 10.5 (Leopard) as well, with Parallels Desktop and Apache still working.

But this configuration does not mean your additional hostnames are working on your virtual machines in Parallels as well. Edit the host files on each VM separately.


Don't play with "/etc/hosts"! The original file is as follows, don't change it:

# Host Database
# localhost is used to configure the loopback interface
# when the system is booting.  Do not change this entry.
##   localhost broadcasthost
::1             localhost 
fe80::1%lo0 localhost

Most likely, you need to change the name and/or address on which you bind in your Apache configuration.


is there any reason you could not have it as       localhost newton testhost something broadcasthost
::1             localhost 
fe80::1%lo0     localhost


And in some cases you want to specify hosts. Especially on internal networks like I have where you do not have a DNS host setup. (House Lans and clusters that do not see outside world)

so I define the ipaddress and names in the host files so that computers can talk to each other without the hassle of setting up a DNS server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.