I don't know how this happened but I have a folder on my D: drive which I cannot delete. The error message is something like this (translated from German):

Element not found
The Element is no longer in D:\Downloads\
Check the Elements location and repeat the process

The folder's name is Yuki (there is a space behind the i) I don't know how the space got there but it seems to be there.
The folder is empty (no hidden elements)

I cannot delete the folder, however I can create a folder inside the folder if I right-click > new I have only one option available which is folder (labeled with an admin-icon (I guess its called that, the blue/yellow shield) If, for example, I create the folder test in Yuki I am able to delete the folder test and I am able to create everything I normally can folder, text-doc and so on (in the folder test)

I already tried to:

  • Remove the folder normally right click > delete (triggers above error)
  • Remove the folder with Cmd (System cannot find the file specified)
  • Remove the folder with "Everything" (nothing happens)
  • Remove the folder with Cmd in safe-boot (System cannot find the file specified)

Now I am out of ideas and hope anyone here could help me (I am sorry if my English is unintelligible I will try to clarify everything that comes up.

I forgot to mention: Yes I tried renaming the folder first I tried to just get rid of the space and got this error message

the source and destination file names are the same

If I try to rename it like Yukirename or even Yuki rename I get the same error message when trying to delete the file.


2 Answers 2


No need to boot into Linux; you can use the special \\?\ syntax to remove this directory (if it's empty) from the command prompt:

rd "\\?\D:\Downloads\Yuki "

Alternatively, if you run dir /x from the directory above the problematic one, you will also see its short name that you can use to get rid of it. If the short name turns out to be YUKI~1, this will also remove it:

rd YUKI~1

If you don't want to remove it right away (e.g. if it's not empty), you can rename it to make it more manageable:

ren YUKI~1 Yuki
  • Thank you the special syntax worked I tried dir /x before but it wouldnt output the 8.3filename. May I ask what this special syntax does exactly? Commented Jun 21, 2017 at 18:22
  • 1
    It tells the Windows API functions to bypass a lot of the checking that they normally do. For example, you can use this to work with very long paths, or to add dots at the end of a file or directory name. This MSDN document has more information.
    – Ben N
    Commented Jun 21, 2017 at 18:35
  • first solution worked like a charm
    – Steve06
    Commented Dec 29, 2023 at 16:01

You could also delete the offending folder by issuing the following command:

RD "Yuki \"

The double quotes are obvious but the trailing backslash is key here.

How can this Windows quirk not have been resolved yet?

  • It worked for me on Windows 7. On the other hand, this issue is very easy to reproduce using "Double commander", as this app allows to create a folder with a space at the end (though same app cannot remove a folder with a space at the end) Commented Feb 12, 2019 at 17:26
  • Works for me on Windows 10, thanks!
    – Ddavid
    Commented Apr 16, 2021 at 18:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .