0

I am faced with very poor speed on my local network between my wired desktop and wireless laptop...

Network setup details (At the time of testing):

Router: NETGEAR Nighthawk AC1900 Dual Band Wi-Fi Gigabit Router (R7000)

Laptop WLAN: Qualcomm Atheros QCA9377 Wireless Network Adapter (5Ghz RSSI: -46)

Desktop LAN: Killer e2200 Gigabit ethernet controller

Laptop LAN: Realtek PCIe GBE Family Controller

Desktop WLAN: Qualcomm Atheros AR9485 (2.4Ghz RSSI: -43)

I used iperf3 on both machines. I performed EIGHT different tests using each combination of devices in each way

Special notes: I am connected to the 5Ghz band via laptop. the ap name is RMSoftware DevNet-5Ghz. WP2PSK is enabled, and WMM is also enabled.

The test below shows even worse performance. Receive window for iperf3 is default 256kb. test time is 10 seconds.

failure

The only combination that failed was the Desktop LAN to Laptop WLAN. The maximum upload from desktop speed reached <1mbps out of the possible 433mbps+ (according to windows network details)

I have tried transferring files from my desktop to my phone over network. I hit my peak wifi speed (Which is great and expected.) I have also tried laptop to phone, also hitting peak wifi speed as expected...

Things that work as expected

  1. RDP between desktop and laptop are hitting full bandwidth (GREAT)
  2. Steam in-home streaming between the two are also (beautifully) working (Awesome!)

Things that don't work between laptop and desktop

  1. Iperf3 testing
  2. Network file transfers (network shares, drives, etc.)

So my question: what is causing uplink throttling with transfers and benchmarks, and how do I fix this. I have a development partition I share so I can work on dev projects from both machines, at any given time.

Generic online suggestions I have tried

  1. Disabling LSO on desktop (Laptop didn't have this) -- FAILED
  2. disabling autotuning (netsh ... autotuning=false) -- FAILED
  3. Tested all the different duplex settings (desktop, as laptop didn't have this) -- FAILED
  4. GPEDIT: configure qos bandwidth limiting (Desktop only. laptop uses win10 home) -- FAILED
  5. Disable QOS via router, desktop, and laptop network settings -- FAILED.

Lastly, I apologize for this chaotic post, I am at wits end.

  • 1
    Thanks for properly documenting your devices. Please edit your question to answer these questions: So you say sending TCP from desktop LAN to laptop WLAN is the only broken direction? What speed do you get in the other direction (from laptop WLAN to desktop LAN)? What RSSI did your laptop have during the test? What upload and download speed does your laptop get on speedtest.net (via Wi-Fi)? Are you sure your laptop was associated to the 5GHz radio of your AP, not the 2.4GHz radio? What does iperf 3 report as the TCP receive window size? Do you have WPA2-PSK and WMM enabled on the router? – Spiff Jun 22 '17 at 1:23
  • 1
    Edits have been made, hope that helps – Ryan McCurry Jun 22 '17 at 2:04
  • Thanks for the edits. Your RSSI looks great. 256KiBytes of TCP receive window should be plenty for 433 Mbps at typical Wi-Fi 3ms RTT. I'm not seeing any clear indicators of what's wrong yet. This is beginning to feel like a case where we'd have to look at a tcptrace and an 802.11 monitor mode packet trace to find what's wrong. This feels like maybe a frame aggregation interop problem between the Wi-Fi devices, or something like that. Hey, if you put your laptop on 2.4GHz instead of 5GHz, do you get decent speed? – Spiff Jun 22 '17 at 4:07
  • Also, since this is feeling like a Wi-Fi interop bug to me, what is your hardware revision and firmware version on your R7000? What is your driver version on your QCA9377? I'm hoping maybe this is a bug that one of those vendors has already found and fixed. – Spiff Jun 22 '17 at 4:10
  • @Spiff sorry for the late reply, Router FW version: V1.0.8.34_1.2.15 updated prior to writing the original post. The QCA9377 driver version is 12.0.0.309 from 4/18/2017. as for the 5ghz vs 2.4, the speed between the two is about the same <1mbps – Ryan McCurry Jun 22 '17 at 22:15
1

This is going to sound crazy. I did some additional searching and found a post. one person suggested to disable windows defender's anti-malware. At first, I disregarded it because it seemed like a long shot and kind of shady... but for the heck of it, I decided to actually try it. After rebooting, I ran another iperf3 test...

image

It's not the full 433mbps, but since I have walls between me and my router, it is much better.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.