-1

[enter image description here

I'm using Excel 2016

I got the following 2 numbers in excel: 27837837879 and 2.79602E+14 (I can see the full number in the function panel as per attachment 279602001944127, also if I expand the column, it still has the number converted to exponent)

These two cells by default are formatted as general. If I now format as text, it still shows as exponential however if I format as number and make the decimal place 0, then only does it show the full number.

One would expect the general and text format to show the full number not the exponential number. I really think its a bug.

If its not treated as a bug, then at least when I format cell as general, it should have further options to not display numbers as exponential.

1

When you enter the number which length is longer than 11 digits, Excel will convert it to scientific notation automatically. 1.23457E+13
If you want to treat it as text, Format the Column as Text before writing the Numbers in it.
By default, Excel uses the General Format (no specific number format) for numbers. To convert scientific to number, use:

  • the 'Format Cells' dialog box.
  • Custom
  • Choose 0 under the options
  • Ok

If it is already exponential and you want to convert to text you can use the following formula:
=Trim(A1)
where A1 is the first Data and drag it down

  • Copy the new Column
  • Paste Special in a new place
  • Values
0

If you only are trying to display the number you need to add a ' before the number. If you need to perform any operation with the number you need to go to the Home menu on Number and expand the formats and go to "More Number Formats" to get the Number format and be able to remove the decimals.enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.