1

Has anyone successfully used SAO Utils on Linux?

The results to the polls even show that some people are using it on Linux. Google turns up useless on this one and I've tried using it multiple times in the past with no success. The display is weird (colorful pixels everywhere? it's hard to describe and I could never get a screenshot because it always freezes the entire system, forcing me to hard-reboot), and the settings for it don't show the save button. Maybe someone has figured out some tweaks to Wine's settings to make it work? I would love to use this with KDE5 to replace the app launcher!

  • I just tried again (last try was sometime last year!). This time I installed directx9 in wine and it ran without freezing and without the colorfullness. unfortunately it showed the widgets but not the launcher itself. It acted like it showed up, just didn't display. The save button was still not in the settings window. – Josh Jun 22 '17 at 23:22
0

I think I figured it out, keep in mind I'm running the following Manjaro Linux Release: 234 (Stable LTS Kernel) and normal WINE (Hence Not Staging).

In order to get it to run you need to run it in a windows environment first, virtual box works fine just make sure you can copy the files out you need to delete the "Web Engine" & "Web Widget" folders from "SAO Utils/Pluggins" (This will fix the giant white square in the center, a few lag issues & issues with it crashing) also you want to change the following settings in the preferences (In windows/VM,VBox)

  • General > Tick The Verbose Mode Appearence > Change to 2D
  • Appearence > (Uncheck All 3D FX Options)
  • 3D Graphics > Set Display mode to Compatability
  • 3D Graphics > Set Texture Filtering to "Nearest Neighbor"
  • 3D Graphics > Set Anti-Aliasing to OFF

Remember to delete the Web Engine/Widget folders in the pluggin folder. You CAN keep the splash screen and you CAN still use the drop down it is visible! Just Copy Paste the SAO Utils Directory into your Wine Directory and all the configs should work. NOTE: Due to some random bug on manjaro at least you cannot save changes made in linux hence why you need another windows PC or Virtual Box to do so. All preference changes must be done in a WINDOWS environment NOT wine As of Sept/22/2017 All the following software/Wine/System files are Up-To-Date (as Released in stable Versions)

  • Side Note: I Do at times have random Freezing when running the SAO menu, but most times its freezes up it get back on track in a few secounds. when it doesnt i just use HTop to kill it but thats a manjaro thing no gurentee this issue would exist outside the current enviroment – ShadowRevenant Sep 22 '17 at 9:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.