14

I need to unzip a .zip file which is password protected.

I am able to unzip the .zip file using a windows PC with 7zip.

I tried several tools Keka, iZIP, unarchiver ... and got always an answer like this "...wrong password". But I proofed the password with the windows PC.

So I tried it with commandline, in this way:

unzip -P password my.zip -d my_folder

But I see the following error:

...unsupported compression method 99

So how can I unzip this file under MAC OS X?

6
  • Not a real solution, but if you can unzip it on a PC, why not just unzip it there, then put it in a different archive with no password for your Mac? – seagull Jun 23 '17 at 11:38
  • What was used to to create the zip file in the first place? – Kinnectus Jun 23 '17 at 11:44
  • Is there something special about the password - non-standard character set etc? I unzip password-protected zip files all the time, using nothing more than the built-in Unarchiver. – Tetsujin Jun 23 '17 at 11:44
  • Because I will get these archive via e-mail being on road and I only have a windows PC desktop in the office – Thorsten Jun 23 '17 at 13:05
  • No password is plain forward, nothing special. Only standard charakters. – Thorsten Jun 23 '17 at 13:05
19
unsupported compression method 99

Means the compression algorithm (99 which is AES encryption) isn't supported.

For OSX the only program supporting this I know of it p7zip (Available with brew and other package managers too).

8
  • No I installed p7zip with Homebrew, did not work. But with new error, "wrong password". But it is the right password, I used c&p. – Thorsten Jun 23 '17 at 14:20
  • 1
    Be careful you didn't copy/paste any whitespaces (space, newline etc). If you're sure of that try a 7z l -slt file.zip – Mikael Kjær Jun 23 '17 at 14:46
  • @Thorsten Also, are there any non-US-ASCII characters (non-English, accented, etc)? If so, you might be running into encoding issues. – Gordon Davisson Jun 23 '17 at 15:03
  • 1
    @Thorsten you need to escape or quote spaces. These 2 commands will work: 7z -p{"pass word"} x pass_word.zip or 7z -p{pass\ word} x pass_word.zip - The first will quote the password and the second will escape the space. In this case do the same thing. – Mikael Kjær Jun 28 '17 at 10:01
  • 2
    I also had the issue with the exclamation mark; using -p'password!' worked for me. The double quotes do not hide the special meaning of the exclamation mark from bash, whilst the single quote means that bash will not do anything with what's inside. – donmartin Jan 16 '19 at 10:43
0

Keka for Mac os really works perfect with zip protected files (error 1 type or unsupporter compression method 99 in Terminal) > Keka prompt for password then you must fill in something with any letters (eg DEMO), then it does some work, then it tells you it failed...

BUT it did NOT : check it out, your unzipped map is just right there besides your zip file. :-)

-1

If you (like me) are trying to unzip ipa file and gets the similar error.

skipping: Payload/App.app/some-file.nib unsupported compression method 99

Check this project https://github.com/sskaje/unzip-lzfse it's worked for me.

It's all about Apple's LZFSE compression:

https://en.wikipedia.org/wiki/LZFSE

https://github.com/lzfse/lzfse

-1

I had exactly the same issue with a zipped pdf file (pwd protected) from a utilities provider. Tried unsuccessfully with Terminal via command line. In the end I downloaded Keka for Mac, and when I tried to unzip the file using Keka it prompted me for the password, and opened the file! Hope this saves someone else some time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.