3

I have been developing some backup software. Somewhere along the line, I ended up with empty files with the same names as some now missing folders. And these files cannot be removed.

The files are on a network drive.

Listing in Explorer

The Properties Dialog:enter image description here

Here's a directory listing at the DOS prompt:

Directory Listing

Here is using DIR /X:

Directory Listing with /X

I tried deleting these files in Windows Explorer, at the DOS prompt, and at the DOS prompt using the short filenames (DEL FNN58M~6). In all cases, I get no error message and the files appears to be gone. But when I refresh, the file is still there.

I first detected these files a couple of months ago. I have rebooted many times since then. But the problem persists.

Does anyone know what else I can try?

EDIT:

So I finally found the time to connect the drive directly to a computer. When I do, these "files" now appear as folders with all expected contents inside. I ran a scan of the drive and it reported no errors were found. Very strange. I think my best best is to reconnect the drives and reset everything and see if they can be recognized as folders.

UPDATE: After looking at the properties of these items for a while, I reconnected the drive to my router and again they appear as empty files.

  • 1
    If on a network drive then that is a different scenario than I thought. The host could be creating the files or someone else who has access to the drive – Eric F Jun 23 '17 at 16:18
  • 1
    Did you check your system for unwanted programs with something like malwarebytes or spybot? – sgmoore Jun 23 '17 at 16:20
  • 2
    Actually as I read and reread - logon to the actual owner system and try and delete them there – Ross Jun 27 '17 at 4:44
  • 1
    This may be completely off, but I noticed that the file owner is Unix User/nobody, so I'm assuming this is probably a SAMBA or something like it? Have you tried deleting it locally from the server itself instead of via a file share? – kazoni Jun 28 '17 at 19:08
  • 1
    Please add new information to the question (edit the question), do not place them (only) in comments. Make it clear it's an edit, so we know which part is the new one. Then the comment may be like "@Kamil I updated the question" to notify the user who asked for clarification. Don't expect users to read all the comments. Help them help you by providing relevant information in the body of your question. I edited the question for you and mentioned network drive. Now you should do the same with this "I'm using the latest version of Windows 10" information. – Kamil Maciorowski Jun 29 '17 at 5:36
1

You mentioned that these empty files have the same names as some now missing folders. I have experienced this problem in the past, also.

There are several possible solutions, although they are not very promising:

Other processes running on the network

As suggested in the comments, there may be virus scanners or other programs that create these files if they are not there. It may be very difficult to isolate what other machine on your network is connecting and writing these files.

You have indicated that you are able to connect the drive to another computer. If you are able to put the drive in a machine not connected to the network, that would certainly help diagnose whether it is a problem with the physical disk, or if the files are coming from another machine on the network.

Corrupted clusters on the disk

When you have files that

  • appear to be deleted, but reappear immediately
  • give a nasty error when their parent directory is deleted
  • have the same name as a deleted directory

this usually means there are some clusters that have become corrupted on the physical disk. This seems somewhat plausible in your case, as backup software was being developed and this disk may have been hit fairly hard.

The best solution is to run chkdsk to fix the damaged areas. This will probably require you to login locally to the machine where the network drive is being stored. Depending on the size of the disk, this process can take many hours, and the drive will be unavailable during this time.

Physical disk needs to be reformatted

This may be unlikely in your case, but is also a possibility. Since you are able to connect the problem disk to another computer, it might be worth copying all the files/directories to a second clean disk -- being careful to skip over the problem files.

After that, try putting the clean disk back where the problem disk used to be. If the problem goes away, you're done! If the problem persists, that would seem to indicate the files are coming from a running process, or somewhere else on the network.

| improve this answer | |
1

According to your information, everything is correct when the drive is connected directly to the computer, the problem only arrives when it is connected to the router as a network drive.

Therefore there is a problem with your router firmware.

I think your options are to, first, find if there is a firmware update to the router. Second, if this does not help, whenever some operation fails in the router, connect the drive to the computer and do there the operation. There is of course also the option to replace the router.

| improve this answer | |
  • In fact, the router firmware was updated last week. The router is a higher-end one and only about a year old. And why, no matter what I do, is it the same 3 folders that have a problem and all others work fine? I can't help but think there is somehow something different about them. I'm just not convinced it's just a bad router. – Jonathan Wood Jun 30 '17 at 10:13
  • What happens if while connected to the computer you delete and recreate the folders? – harrymc Jun 30 '17 at 11:00
  • +McDonald's Unfortunately, no. The problem persisted from the time before the firmware upgrade to the time after. I appreciate everyone's input but while it appears I can access my data normally by connecting the drive directly to a computer, this bug remains a complete mystery. I can try and provide additional information if it would help, but frankly I'm not even sure exactly what "configuration specs" refers to. These are just Western Digits USB drives. If you ask something specific and I can find the information, then I can provide it. – Jonathan Wood Jul 4 '17 at 18:25
  • I would also check if the disk is formatted in a format that is fully supported by the firmware. – harrymc Jul 5 '17 at 16:35
  • How would I determine that? – Jonathan Wood Jul 5 '17 at 17:26
0

You can try to see if you may be able to rename the folder, then see if you are able to delete it.

If not, then open regedit, click on File (menu bar) and Export. Navigate to your desktop, and see if you may be able to delete the folder from within this "Export Registry File" dialog, then just close the dialog and regedit.

Hope this helps.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.