0

Local LAN, Ubuntu laptop and Viasat Surfbeam SM2101 modem are connected to the router, wired connection. I can't find an internal IP address of satmodem connected to the router. Router only show laptop connected. I tried scan network range 192.168.1.0 - 192.168.1.255 use angry ip scanner, nmap, but they does not show satmodem. I'm not sure does it have DHCP enabled or not, there is no reset button. I tried also directly connect ethernet port of satmodem to the laptop and scan with ip scanner, also use nmap -sP 192.168.1.0/24, but it does not show it. The Network LED indicator on the modem is light means it working. I have no manual on that device, but in the configuration Guide for old version of satmodem was specified that during modem configuration, the "Support PC’s Operating System" should be configured for a static IP address of 192.168.1.2. Not sure that that's the case, as such configuration was used in quite old hardware.

  • What is the IP address of your linux pc? – MariusMatutiae Jun 24 '17 at 7:13
  • 1
    The internal IP address of linux laptop is assigned by router, it's within 192.168.1.x – triwo Jun 24 '17 at 11:02
  • Did you try nmap -Pn -T5 -A 192.168.1.2? – MariusMatutiae Jun 24 '17 at 12:39
  • 1
    Alternatively, the satmodem has a static address within a different network, the only othe rpossibility being 192.168.0.0. To establish whether this is the case, give your Linux pc and address within 192.168.0.0/24, then try a scan as nmap -Pn -sn 192.168.0.0/24. – MariusMatutiae Jun 24 '17 at 12:43
0

Please update your question with the exact brand and model of the Satmodem.

Ideas:

1) Start tcpdump -i eth0 (or Wireshark) on laptop, connect satmodem directly to laptop, see if it broadcasts anything (like a DHCP request).

2) You probably did that, but when scanning for IPs, make sure you have the correct address and netmask statically assigned to eth0 (check with ip addr), and no other program tries (e.g. network manager) tries to interfere with that.

3) Connect satmodem directly to laptop, statically assign each of the complete private network ranges to it, scan complete range. Start with 192.168.0.0/16.

4) Sometimes embedded devices behave differently directly after startup when the boot loader is running, e.g. they may react to different static IPs etc. Or there may be special modes you can get into by pressing the power switch for a longer time etc. This might provide an angle.

| improve this answer | |
  • 1)I tried sudo tcpdump -v -i eth0, modem does not broadcasts anything, only PC communicates. 2) I've checked the connection information, all looks correct. 3) I tried scan the range 192.168.0.0/16, only laptop IP was found after about 30min scan, but I didn't wait until it finished scanning the full range as it take too long time. I haven't tried a private address space 10.0.0.0/8, not sure it could be within these range, this range is very broad. 4) it have no separate power button. Also, sometimes hardware are somehow "glued" to the last IP address, and only full reset can unbind it. – triwo Jun 25 '17 at 11:03
  • 1
    How did you scan? nmap and portscanners can set the scan interval (which is often "polite" by default). As you are scanning LAN, you can crank this up to max, this will scan much faster. Another idea: Use ping -b to do a broadcast ping (not all devices respond to that), or try arping. – dirkt Jun 25 '17 at 11:17
  • First I used Zenmap with 'regular scan' profile, then tried 'Quick scan' (nmap -T4 -F), both seems slow. Also angry ip scanner with default settings. – triwo Jun 25 '17 at 11:32
  • Ok, I tried ping scan (nmap -sn), and managed to got it, 192.168.100.1 – triwo Jun 25 '17 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.