3

I am trying to set up File sharing on a friend's machine who is using Windows 7 64 bit Ultimate edition. In advanced sharing settings, I select the radio button "Turn on file and printer sharing" and click on Save Changes. But when I come back to the screen, it reverts back to off.

I searched on the net and found many people facing similar issues, and I tried many steps like turning off WIndows firewall, netsh command, checking predefined rules in Firewall, starting the Server service and HomeGroup Listener service, verifying all required services are started, group policy editor, running the troubleshooter, etc, but nothing seems to be working in my case.

I am not able to see this computer in the Network Places, even though Network Discovery is on. The computer is connected to internet using a wireless connection. The HomeGroup troubleshooter says "Some Homegroup problems are network related" but the network troubleshooter does not find any problems.

Is there no tool to forcibly turn this setting on?

Will really appreciate any help on this. Already spent a lot of hours on this simple yet nagging issue.

Thanks.

EDIT 1:

I remember having turned off SMB through DriverPack online tool, while installing the drivers. Could that be the reason? If so, how can I reenable it without having to reinstall OS?

4 Answers 4

2

My issue finally solved after several hours, without requiring to reinstall OS or go back to a previous restore point.

The sequence of commands which did it are given below. I ran them in Windows PowerShell (right click->Run as administrator)

  1. Enable SMBv1 on the SMB server:

    Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters" SMB1 -Type DWORD -Value 1 -Force

  2. Enable SMBv2 and SMBv3 on the SMB server:

    Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters" SMB2 -Type DWORD -Value 1 -Force

  3. Restart computer

  4. Enable SMBv1 on the SMB client:

    a) sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi

    b) sc.exe config mrxsmb10 start= auto

  5. Enable SMBv2 and SMBv3 on the SMB client:

    a) sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi

    b) sc.exe config mrxsmb20 start= auto

  6. Restart computer

All the above commands are given in the Microsoft KB 2696547 article: https://support.microsoft.com/en-ie/help/2696547/how-to-enable-and-disable-smbv1-smbv2-and-smbv3-in-windows-and-windows-server. I had tried these commands earlier too, but missed to run the commands 4 and 5 above for the SMB client. Now after running all the commands, the issue is resolved!

Hope someone finds it helpful, and saves a few hours of time and endless frustration.

1

Sometimes the issue is because of a service that is stopped or disabled. This is suggested by the fact that the setting enables and immediately disables, as you mentioned. Be sure to have these services enabled (the top 5 should be set to automatic) and running:

Workstation
Server
HomeGroup Provider
HomeGroup Listener
Routing and Remote Access
Remote Procedure Call
Function Discovery Resource Publication
Function Discovery Provider Host
0

This resolution may work as found on another post here, though you may have already tried much of these. I'm rewriting the post's steps here.

Using an administrator command prompt use these two commands:

netsh advfirewall firewall set rule group="File and Printer Sharing" new enable=Yes
netsh advfirewall set currentprofile state on

Alternatively, though I recommend the former, you could do it by using the Windows interface. In fact, you could use both methods if you wanted (start with these steps first, then try through the Network and Sharing Center, then the steps above, for likely best results.).

  1. Open run (Win+R), and type in wf.msc
  2. Navigate to "Inbound Rules," then in the alphabetized list find, select, and highlight all Rules starting with "File and Printer Sharing..." Right click the selection and choose "Enable Rule."
  3. Same as 2, but with "Outbound Rules." Navigate to "Outbound Rules," then in the alphabetized list find, select, and highlight all Rules starting with "File and Printer Sharing..." Right click the selection and choose "Enable Rule."

For Windows 8 or 10 Users: If you believe you have disabled SMB, in Powershell (as Administrator) run these commands then do the steps above.

Set-SmbServerConfiguration -EnableSMB1Protocol $true
Set-SmbServerConfiguration -EnableSMB2Protocol $true

For Windows 7 Users: Do what it says in AllSolutions's Answer.

You can also check its state with:

Get-SmbServerConfiguration | Select EnableSMB1Protocol, EnableSMB2Protocol
4
  • I had already tried this one, but did not help. I am strongly suspecting that disabling SMB has broken the file sharing, as given in this link: sevenforums.com/network-sharing/… Jun 24, 2017 at 21:23
  • @AllSolutions, I have edited the post describing how to turn on SMB, try that.
    – El8dN8
    Jun 24, 2017 at 21:24
  • It seems the command you have given is for Windows 8 and Windows Server 2012, I am trying a different command for Windows 7 as given in this link: support.microsoft.com/en-ie/help/2696547/… Jun 24, 2017 at 21:29
  • But instead of running the command through PowerShell, I already tried editing the Registry directly and also restarted the system. Still the problem persists. Jun 24, 2017 at 21:30
0

Necropost, I know, but this exact problem turned up for me with the update of Windows 10 version 2004, and was not an issue before that. This feature requires "Workstation" service to be running; if you can't start it manually, check to be sure you have "Browser" or "Computer Browser" service installed, and if not, install the SMB 1.0/CIFS File Sharing Support windows feature. Once that was installed and I rebooted, Workstation service came up, and the issue was resolved!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.