2

The following steps reproduce the problem:

  1. Install Ubuntu 16.04.2 LTS
  2. sudo apt-get install xpra
  3. Reboot
  4. Login screen hangs (no response from keyboard and mouse, no cursor at all)

At first, I didn't know it was xpra. After some trial and error, I narrowed down to it because once xpra is installed, as long as I don't log out or reboot, there seems no problem. Once I reboot, I cannot type my password in the login screen, nor can I show the terminal via shortcuts. I tried reinstalling lightdm and ubuntu-desktop but in vain.

How can I fix this, using xpra or alternative without such problem?

2 Answers 2

1

Don't use the version of xpra from the Ubuntu repositories. Those are fundamentally broken, see problems with distribution packages. Use the official packages from xpra.org instead.

1
  • 1
    I experienced this (mouse + keyboard non-functional after reboot) with Ubuntu 18.04 and the xpra package from Ubuntu's repo. Had to SSH into the box to remove the package. Using the xpra repo solved the issue.
    – joat
    Dec 30, 2019 at 12:19
0

If you can get access to the system you can change the runlevel of the system to avoid start with the login of xpra, if you set the runlevel to 3 you are telling to the system to start and shows the terminal login, and from there you can perform any procedure you need, you can try uninstall xpra or you can try testing the xinit and xorg binaries to see if your user can execute it without any problem like the freezing.

Ubuntu 16.04 uses systemd instead of init and hence the concept of runlevels is replaced by the term targets. So there is indeed a mapping between init-based runlevels and systemd-based targets:

Mapping between runlevels and systemd targets

│Runlevel │ Target │

│0 │ poweroff.target │

│1 │ rescue.target │

│2, 3, 4 │ multi-user.target │

│5 │ graphical.target │

│6 │ reboot.target │

Now, to just change the "runlevels" in 16.04, you can use for eg:

sudo systemctl isolate multi-user.target To make this the default "runlevel", you can use:

sudo systemctl enable multi-user.target sudo systemctl set-default multi-user.target

When a GUI is used you are using a runlevel of 5, the multi-user is the runlevel 3 that you can use to avoid the login freezing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.