Whenever I try to save a spreadsheet as 'CSV (Comma delimited) (*.csv)' it appears to save itself as a CSV but has not actually converted the file type.

As a test, to make sure I wasn't going crazy, I saved a self-created Excel spreadsheet with multiple tabs and formatting as a CSV and there was no "may contain features that are not compatible" error, it just saved. If I navigate to where the file is, I can see the file extension and it definitely saves '.csv'. I right-click to check the Properties of the file, and look at the Details and it confirms that the file type is a 'Microsoft Excel Comma Separated Values...'.

However, when I go to open the file it warns me that the file "is in a different format than specified by the file extension" and the file retains the multiple tabs and formatting.

This error has only just started occurring.

I'm using Excel 2010, 32-bit.

  • 1
    Try opening it in Notepad and tell us what you find – Vylix Jun 26 '17 at 15:39
  • Welcome to the site. What OS are you using? Have all Office Updates been installed? Sounds like Excel may have corrupted the file when it saved. Try the Save As again. There are two options for CSV, one for Mac and one for PC. Make sure you clicked the correct one. – CharlieRB Jun 26 '17 at 15:56
  • 1
    Right, solved it. I had recently installed the Google Drive add-on ( support.google.com/drive/answer/6167634 ). Uninstalling this instantly fixed the issue. – Jd S Jun 27 '17 at 9:28
  • 1
    @JdS: Glad you found a solution. On SuperUser it is encouraged you self-answer your questions if you have found a working solution. This way other users with a similar issue can easily find the solution, and users looking to answer a question know this question has been solved. – Wouter Jun 27 '17 at 11:48
  • 1
    @Wouter Done, thanks. Will mark my comment as the answer tomorrow when it lets me. – Jd S Jun 27 '17 at 13:19

It turns out that every single file type was being saved as an XML file, regardless of what was chosen at the File Save screen. (Thanks to @Vylix for suggesting looking at the files in Notepad.)

I had recently installed the Google Drive add-on ( support.google.com/drive/answer/6167634 ), uninstalling this instantly fixed the issue. Although how the add-on was causing Excel to act in this way is a mystery.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.