0

Problem: after resizing partition C, the HDD does not allow the computer to boot and stucks at the press DEL or F2 to enter bios message

Specs:

  • Windows 7 (yes, I know it's old... but it worked until resizing disk C)
  • SATA HDD
  • an Asus motherboard with UEFI bios

How I broke it :-)

On one physical SATA HDD with two logical disks (C and D) I used Aomei Partition Assistant to:

  • shrink and move logical disk D (so as to free some unallocated space left to disk C)
  • extend the system disk (or partition?) C (so as to have more free space)

After reboot, the computer always stucks at the message: "Press DEL or F2 to enter UEIF bios"

Of course, nothing happens when I press the keys.

What I tried:

  1. Unplug this SATA HDD and enter UEFI bios OK. So, keyboard and bios is OK.

  2. I enabled SATA hot plug and did a trick:

    • unlugged the problem HDD
    • successfully booted into UEFI bios,
    • plugged a USB drive with Windows installation image
    • launched Windows repair utility
    • plugged the problem SATA and
    • Windows repair utility does detect the HDD and says it successfully repaired the boot records However, when I restart the computer, it won't boot with this HDD..
  3. I checked with Paragorn utility, the HDD has data on it.

Questions

  1. How can I boot from this HDD?
  2. Does it matter if I try another (not Aomei) hdd utility to restore the hdd?
  • 1
    Good thing that you have an image backup so you can restore it to the way it was before. – SDsolar Jun 26 '17 at 16:37
0

In your answer, you mention there is a partition C and a system disk. I believe what happened is that you incorrectly setup you C partition and the boot partition.

There are TWO partition necessary to boot Windows 7. A small system partition (usually about 200 MB) and the C partition. The system partition has no Disk Letter assigned to it. This small partition (call it the System partition) needs to be the primary boot partition. All there is on this partition is a boot loader. The C partition is where your Windows directory sits.

Basically, BIOS will boot the System partition and the boot loader will take over and boot windows from the Windows folder.

0

After two days I figured it out:

It's the Aomei utility's incompatibility with the motherboards with UEFI bios.

Details:

The Aomei utility creates a script to run after boot and before the OS loads. This script is not compatible with UEFI bios, it just freezes. And the computer stucks before booting.

Solution:

I plugged the HDD to another computer with plain old BIOS instead of UEFI. It allowed booting from the HDD, launched the Aomei pre-os utility, completed resizing the partition, rebooted again.

Swapped the hdd back to the UEFI computer, now it works.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.