2

So, my problem is simply that I can't get screen started on my user account. When I invoke it as superuser it works, under any circumstance, like a charm, but until now (that is, in the about last THREE and more hours of troubleshooting) there wasn't a single instance in which it would spawn a new session.

To give some context, this morning I installed Debian 9.0 (stretch) on a 64-bit processor. In the previous installation (Debian ~8.0) screen worked without flaws.

Here is a non-exhaustive list of my attempts at solving this issue:

  1. I unmounted the partition mounted at my home directory, and logged in with my user account in a new environment where there wasn't trace of my old custom config files;
  2. I tinkered with the $TERM-like variables, and also tried using tset;
  3. I tried installing an older version of screen (4.2.1-3+deb8u1);
  4. I made an attempt at running apt-get purge screen and then installing again the distribution-provided package.

None of these attempts (and even others) had an impact on how screen behaves. All of the times I did screen; echo $? ($? being a status-code variable, IIRC) I got 0 printed on my console.

I am resorting to this Q&A as a last and desperate solution :'-).

  • 1
    Hint: perhaps the problem lies in the system configuration of my user. I also did some research on this but nothing that I examined seemed suspicious. And if it interests you, $TERM is always equal to xterm-256color. – Acsor Jun 26 '17 at 22:05
  • Please provide at least the error message you're getting or state that you don't even get an error message. Otherwise you likely won't get any helpful answers. – Axel Beckert Jul 23 '17 at 18:33
  • 1
    @AxelBeckert I don't get any, as implicitly stated before. This is what I see when typing screen on console, with my normal account: none@vacuum:~$ screen\n none@vacuum:~$ echo $?\n 0\n . (Edit: comments don't allow newlines; added "\n"s to give an idea.) – Acsor Jul 23 '17 at 18:41
  • Thanks. Stating things implicitly is probably not the best idea here. At least I don't see where that would have been. I think the best is to continue the debugging on the screen-devel mailinglist. – Axel Beckert Jul 23 '17 at 19:03
2

As Amadeusz Sławiński pointed out on the screen-devel mailing list and I confirmed in the according Debian bug report, this is caused by your user name none which seems treated special by GNU Screen.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.