I'm trying to install the google cloud print driver for Windows (version 58.0.3020.0) to be able to print normal word documents to my google cloud-registered printers. When I run the installer I get the following error message:

Error message

Translated to English, it says:

Error 0x80070705 occurred within the installer with the error message "Unknown printer driver"

C:\Program Files (x86)\Google\Cloud Printer\58.0.3020.0\debug.log contains:

[0619/143106.829:WARNING:setup.cc(245)] Unable to open printer
[0619/143110.688:WARNING:setup.cc(165)] Uploading the printer driver package to the driver cache silently failed. Will retry with user UI. HRESULT=0x800f0242
[0619/143131.064:ERROR:setup.cc(185)] Installing the printer driver failed.
[0619/143131.064:ERROR:setup.cc(275)] Unable to install driver.
[0619/143131.064:ERROR:install_utils.cc(100)] The printer driver is unknown.

[0619/143131.064:INFO:setup.cc(426)] The printer driver is unknown.
[0621/191645.908:WARNING:setup.cc(245)] Unable to open printer
[0621/191647.104:ERROR:setup.cc(185)] Installing the printer driver failed.
[0621/191647.104:ERROR:setup.cc(275)] Unable to install driver.
[0621/191647.104:ERROR:install_utils.cc(100)] The printer driver is unknown.

Where the last 6 lines repeat a couple of times (with different numbers at the start), probably because I have tried to install the driver multiple times already.

I have tried both the most recent "normal" chrome version 59.0.3071, and the current canary version 61.0.3141.0 for installing the driver. I'm running Windows 10.0.14393 on a HP ProBook 4730s.

Does somebody know what the problem is?

  • Have you installed the required XPS Essentials Pack? – DavidPostill Jun 27 '17 at 12:02
  • @DavidPostill Wow I can't image I didn't read that. There are only versions for Windows Server 2003, Windows Vista and Windows XP though, which one should I use? – Todd Sewell Jun 27 '17 at 12:05
  • I've no idea... :) – DavidPostill Jun 27 '17 at 12:07
  • Turns out that isn't the issue, XPS is included in Windows starting from W7. – Todd Sewell Jun 27 '17 at 15:44

USE the beta version https://tools.google.com/dlpage/cloudprintservice it will solve the issue

  • Consider adding some quoted reference to this answer supporting what you state in case the link ever dies so the answer content is still available that is currently only available via that link per your suggestion. – Pillsbury IT Doughboy Dec 10 '17 at 16:24

I found no solution that fixed the issue for me on Windows Server 2016 x64. It seems like it fails with the commonly mentioned 0x80070057 error:

[0429/234050.669:ERROR:install_utils.cc(100)] Wrong parameter.
[0429/234050.669:INFO:setup.cc(426)] Wrong parameter.

For me the fix was to copy gcp_portmon64.dll to Windows\System32 (My system is x64, I assume x86 needs the gcp_portmon.dll instead. Then I made a copy of C:\Program Files (x86)\Google\Cloud Printer\58.0.3020.0 (These files install when the installer fails) Modified the gcp_driver.inf file adding just at the bottom of the file: (I assume you remove the '64', if you are on x86.

"Google Port Monitor" = GooglePortMon

CopyFiles = @gcp_portmon64.dll
PortMonitorDll = gcp_portmon64.dll

Then running the virtual_driver_setup.exe file, and it should install the port monitor, else try it manually from devices and printers => server properties. If it installs, try run the original installer again, as modifying the file breaks digital signing, so the printer wont install. I hope this helps anybody a bit further.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.