Following up on the questions Permanently disable num lock in Windows? and Windows INSERT key anti-functionality accidentally triggers; how to stop it permanently?, I am trying to disable caps lock, num lock, and insert (or numpad-0 on my keyboard). Combining those answers, I tried the following. Apparently I've got it wrong. It does disable caps lock and num lock, but numpad-0 still puts me into overtype mode, which I never want, ever ever, ever, ever.

  1. Click Start > Run
  2. Type "regedit"
  3. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout
  4. While Keyboard Layout has focus, go to Edit > New > Binary Value
  5. Enter "Scancode Map" as the name
  6. Enter the following as the Data:

    00 00 00 00 00 00 00 00
    06 00 00 00 3A 00 00 00
    00 00 3A 00 00 00 45 00
    00 00 52 E0 00 00 00 00
    00 00 00 00 00 00 00 00

How can I permanently disable all three of the evil modal keys?

2 Answers 2


This did it for me. Finally. Save the following as a file, with a name like "DisableCapslockNumlockInsert.reg" (The ".reg" extension is important; the rest doesn't matter.) Double click it and click through all the warnings. Then restart your computer.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,05,00,00,00,00,00,3a,00,00,00,52,e0,\

A bit of explanation:

  • I'm pretty sure the backslash is a telling it that the data go to the next line. If your data are all on a single line, you probably don't need it.
  • the "05" is one plus the number of keys you are mapping.
  • the "00,00,3a,00" disables caps lock.
  • the "00,00,52,e0" disables insert.
  • the "0b,00,52,00" remaps the insert on your number pad to the "0" key. If you prefer to just disable this key, use "00,00,52,00" instead.
  • the "00,00,45,00" disables num lock.
  • The zeroes other than the above are simply part of the format for that particular registry key.

Alternatively, to remap caps lock to control:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,05,00,00,00,1d,00,3a,00,00,00,52,e0,00,00,45,00,\

The Regedit way is confusing, I've tried it myself, get AutoHotkey and right click, new, autohotkey script and paste this in:

CapsLock::return NumLock::return Ins::return

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .