13

I have a Microsoft Sculpt wireless keyboard with separate keypad. I'm working with Windows 10 Pro on a Dell Ultrabook, Intel I5 64bit X64 and O365 and Office 2016. I also have two screens in addition to the laptop screen.

My problem is, when I change screen or window and start to type, the keyboard misses the first letter... each and every time. I also have this keyboard and mouse package at home on a Dell desktop with the same operating systems and office package and it does exactly the same thing. Even in this window, when I clicked on another screen and back again, and started typing, the first letter was missed.

Unfortunately, my Ultrabook is a work laptop and therefore I have no admin rights, however, if someone can make a suggestion, I could at least point our IT department in the right direction and perhaps use the information to fix the problem at home.

1
  • I am having the exact same problem as you. Have you tried the usual shenanigans, like changing batteries or trying tomove the receptor closer to you? Commented May 28, 2018 at 17:48

3 Answers 3

8

I was able to workaround the issue using the basis of foal's answer, but wanted to note that only one device actually needed to have it's power management setting modified:

  1. Open the device manager (WIN+X then select Device Manager).

  2. Find your keyboard and select it.

  3. Switch to the "Devices by connection" view (in the View menu).

  4. Find the nearest parent USB device that has Power Management options

  5. Uncheck "Allow the computer to turn off this device to save power"

2

I have fixed the same issue with the following steps:

  1. In device manager select the keyboard and then switch to view "devices by connection" enter image description here
  2. Open properties for each node in the tree that have "Power management" tab and switch off the checkbox "Allows the computer to turn off this device to save power" enter image description here

Hope it will help somebody.

1
  • This worked for me! Disabling power save on the device itself was not sufficient in my case (Dell laptop plugged into USBC dock, keyboard receiver plugged into the dock).
    – 0x574F4F54
    Commented Jan 22, 2020 at 14:06
1

I had that problem too. SOlved when I changed the USB Receiver from a USB Hub to a USB Port in the notebook.

My working theory is that the USB Hub does some kind of power throttling, and uses the first keystroke as a "device wake-up call".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .