0

I'm using FFmpeg for a project concerned DASH (Dynamic Adaptive Streaming over HTTP). For the build and installation of ffmpeg I've followed the "Original Guide" Compile FFmpeg on Ubuntu, using the compile commands in the guide (not the sudo apt-get install ...). Using on the terminal ffmpeg I have the error Unrecognized option 'x264opts'. Error splitting the argument list: Option not found . I though the cause would be the library libx264, but I have installed it during the procedure. Note that the command that give the error is

ffmpeg -hide_banner -i Helicopter.mp4 -threads 0 -vf "scale=426:240" -c:v libx264 -preset slow -profile:v main -level 4 -g 60 -keyint_min 60 -x264opts "keyint=60:min-keyint=60:no-scenecut" -b:v 300k -maxrate 300k -bufsize 600k -r:v 30 -an -y -f mp4 Helicopter_240p_300.mp4

Any suggestion? Thanks in advance

Here the complete bash input and output : Pastebin Link

  • 1
    Show the full banner of ffmpeg. – Gyan Jun 28 '17 at 17:53
  • What does it changes? The probleb is the libx264.. this is the pastebin complete issue link – Alberto Jun 29 '17 at 7:53
  • If configuration: --disable-x86asm is the full config, then you don't have libx264 enabled. You should see --enable-libx264 as well. – Gyan Jun 29 '17 at 8:39
  • How can I fix this? – Alberto Jun 29 '17 at 8:47

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.