2

I recently upgraded to Debian 9 Stretch. It includes VIM 8.

Previously, I could select text with the mouse and copy and paste it using the terminal application. Now this initiates "visual" mode which I have read the documentation for.

Using the mouse, it selects text using VIM instead of the terminal, and I cannot copy it.

I can't see any way of disengaging this, except recompiling with visual mode disabled.

There must be a way, right?

2

in stretch, VIM 8 uses a new defaults.vim file in /usr/share/vim/vim80/

in this file i commented out the set mouse=a and it had the desired result. i don't run vim heavily customised, so i am happy with this.

  • This will be overwritten when vim gets updated, doesn't it? – steffen Aug 7 '18 at 20:36
0

In /etc/vim/vimrc strarting from line #12 is reported how to solve your problem (globally).

Enabling the line containing:

let g:skip_defaults_vim = 1

you can disable vim defaults and, after that, set what you want.

Otherwise you can do that in a local ~/.vimrc

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.