Every time I open my tiddlywiki.html file in IE8, I get a warning bar:

To help protect your security, Internet Explorer has restricted this webpage from running scripts or ActiveX controls that could access your computer. Click here for options.

and tiddlywiki doesn't display. If I select "Allow Blocked Content..." it's all fine.

I want to change whatever IE8 settings necessary so that I don't have to do this. Anyone know what setting that would be?

I tried adding my c:\users\me\tiddlywiki.html file to the "Trusted Sites" in IE->Tools->Options->Security but it says the URL doesn't match some regular expression validation.


There are some Tweaks described at the tiddlywiki.org pages.

  • 1
    Nik, the tiddly pages have been restructured and all three links redirect to the same page now. Of course, without the expected information. Would you mind to update your links here? Thanks! – Jens May 14 '11 at 8:57
  • @nik Can you update these links? – Phrogz Jun 4 '12 at 20:16

Have you tried opening up the advanced options under control panel, internet options and setting the "Allow active content to run in files on My Computer" to enabled? That should do the trick.


TiddlyWiki uses the ActiveX FileSystemObject to access the filesystem under the internet explorer. To use this ActiveX object you don't need to set the browsers security level to low as described on some pages. You should only set one security setting "Initialize and script ActiveX controls not marked as safe for scripting" to "Prompt" or "Enable". That's it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.