1

I have a laptop running Windows 10 with en-US and en-GB keyboard layouts installed. en-GB is the default. Every so often, seemingly at random, my keyboard layout silently changes to what I assume is a United States keyboard layout; so for example shift+2 produces @, shift+3 produces # and so on. I have looked in considerable detail into what the key combinations are for changing keyboard layouts. I've also checked in the language advanced settings that the key combination for switching layouts is the default, which it is.

  • Ctrl+Shift does nothing
  • Alt+Shift does nothing
  • windows key + space does nothing

I also note that Windows simply will not display the language bar, no matter what combination of language bar-related options I choose. This is presumably because this is a machine configured for just one language - the one I use, en-GB. Nevertheless it sometimes decides to change its language settings in a way that is completely hidden and doesn't respond to the normal procedure for changing it back.

Why? What can I do about it?

0

Well, it's a new day, and out of curiosity I hit Ctrl+Shift on the off chance Windows might have changed its mind since yesterday.

It has. The language hotkeys now work. All that has happened in between asking that question and now is that I have put the laptop to sleep, and woken it up again.

Therefore I am emphatically confident that this is a bug in either Windows or my keyboard driver.

0

I had similar issue and sleep+wake helped (Thanks Tom W !)


DETAILS

I have the following setup:

  • Windows 10 64bit 1703 (build 15063.608)
  • My UI language is English
  • I have only one input method (keyboard layout): Polish
  • well I kinda' also have US layout but I disabled it, because:
  • I disabled option to switch layouts for apps separately, I disabled the language list, and forced only Polish to be used,
  • I have disabled the hotkeys for switching layouts (set to (None))
  • I disabled the language bar (strange that when I turn it on, then I still can use it to switch to US layout; however, like I wrote, normally I disabled everything possible, so it was disabled when the problem accurred)

The following problem occurred:

  • at some moment it happened that I lost my Polish keyboard layout, so I could not wrote with Polish characters like ĄĘĆŁŃÓŚŻŹ through RIGHT ALT + key.
  • remember that it could not happen accidentally because I disabled hotkeys and all the other stuff; i tried Ctrl+Shift and probably Alt+Shift and it did not help
  • what's more, at least in one program I could not copy and paste Polish words (copied "koło" but it pasted "kolo" hahahaha); now I see that the same happens if I enable language bar and switch to US layout
  • I am not sure what was the reason, perhaps because of UltraVNC app or some other program, or just because of Windows.

Solution:

  • I put the computer to sleep and wake it up, and immediately everything works as it should without me doing anything!
  • (i.e. I can write in Polish layout right after computer wake, and of course I can also copy-and-paste Polish words in that program that had problems with it)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.