Because there's no sudo command in Cygwin, scripts that I want to run fail with

./install.sh: line N: sudo: command not found

What's the standard way for getting around this? Editing the scripts to remove sudo? Getting some sudo-like tool for Windows?

  • @dotancohen, I hope I picked the right one. Mar 30, 2015 at 0:16
  • Looks like a good solution to me! Cygwin support has certain gotten better in the past five years!
    – dotancohen
    Mar 30, 2015 at 7:35
  • 1
    See stackoverflow.com/questions/4090301/…
    – Benj
    Aug 3, 2016 at 9:29
  • @Benj, I wonder why that question didn't get migrated here, too. Aug 3, 2016 at 22:25
  • @JasonSundram indeed. Let me know if the answer is moved, I'll then update the link.
    – Benj
    Aug 4, 2016 at 7:52

9 Answers 9


I wrote the (rather simple) TOUACExt for SUDO for CygWin, a pre-beta shell script automation that approaches to the behavior of classical sudo for Linux:

  • Open and closes automatically sudoserver.py when needed.
  • Requests UAC Elevation Prompt.

Installation requires copying the four .sh scripts to some path directory, creating an alias and just a few more steps detailed in the thread.

The results: you type a single sudo YourCommand and you get the output of it, without having to worry about the rest of the process.


One way is to create a fake "sudo" command with the following content:



This will allow the install.sh to continue, because sudo is found.

This doesn't elevate privileges like real sudo does. If you really need elevated privileges start cygwin shell with from an account with administrative privileges (XP) or r-click on cygwin.bat and "run as administrator" (Vista,Win7)

  • 5
    Just out of curiosity from someone who doesn't speak fluent bash: Why does this work? The manpage doesn't say anything about $@ doing anything sudo-like. Instead it's just all arguments to the script. And wouldn't the quotes around it be superfluous in that case? Otherwise if you'd do a sudo foo bar then it tries executing "foo bar" as a single command which probably doesn't exist given that irrational fear of spaces on UNIX-like systems.
    – Joey
    Mar 23, 2010 at 10:29
  • 8
    @Johannes: "$@" (when double-quoted) works differently from "$*": it expands to a separate word for every positional variable. Example: If $1 == "foo bar" and $2 == "baz", then "$@" is "foo bar" baz - one word for each parameter (unlike "$*", which results in "foo bar baz" as one word). See manual of bash, section Parameters, subsection Special parameters. The end result of Peon's script is that it executes its arguments exactly as they were passed. Mar 23, 2010 at 15:22
  • 1
    Ah, ok. And where does the sudo part come in? Above snippet doesn't do anything remotely in that direction, right?
    – Joey
    Mar 23, 2010 at 15:38
  • 2
    @Johannes: In Unix, a real sudo would raise privileges from mortal to root before running the command. In Cygwin, there is no such thing, so Peon's fake script (which you're supposed to name sudo) just runs the command directly without changing its privileges. (This means you may need to run ./install.sh as Administrator.) Mar 23, 2010 at 15:49
  • 2
    @grawity: runas should work, it doesn't rely on UAC and prompts for a password by itself. I was just confused why the script in the answer apparently didn't do what the name implied which I assumed was the goal. Sorry for my stupidity ;-)
    – Joey
    Mar 23, 2010 at 17:12

I found the answer on the cygwin mailing list. To run command with elevated privileges in Cygwin, precede the command with cygstart --action=runas like this:

$ cygstart --action=runas command

This will open a Windows dialogue box asking for the Admin password and run the command if the proper password is entered.

This is easily scripted, so long as ~/bin is in your path:

$ cat ~/bin/sudo
cygstart --action=runas "$@"

$ chmod +x ~/bin/sudo
$ sudo elevatedCommand

Tested on 64-bit Windows 8.

  • 5
    The problem with the cygstart method is that it only works for Windows commands/programs. You can not do sudo ls. SUDO for CygWin is neat, but still lacks some good sudo command in it. Apr 13, 2014 at 20:59
  • Thank you, Sopalajode. In what situation have you needed to use sudo ls in Cygwin?
    – dotancohen
    Apr 17, 2014 at 10:04
  • 3
    Oh, no, @Dotancohen, it was just an example. You can use sudo for CygWin to run any Windows or CygWin command. It is very useful for me. But the more practical method I have found is this script wrapper for SUDO for CygWin I developed: superuser.com/questions/741345/… (still in Beta, but seems to work ). With it you can comfortably order things like sudo net start vncserver. Apr 17, 2014 at 10:22
  • @SopalajodeArrierez: That is absolutely terrific! Thank you for the post and the link.
    – dotancohen
    Apr 17, 2014 at 12:15
  • 1
    tried almost everyother solution. this is the only one that worked
    – rajesh
    Jun 9, 2020 at 11:40

Building on dotancohen's answer I'm using an alias:

alias sudo="cygstart --action=runas"

Works as a charm for external programs (not shell built-ins, though):

sudo chown User:Group <file>

Sudo (Elevate) for Windows™

I do a lot of work on the command line in Windows™.

In Cygwin itself I believe you can run a root command with su -c /the/cmd as for sudo itself within Windows™ file-system elevating the user's permissions from the command line, If you are an administrator, this will work great for you. Otherwise, use runas and get admin's pass ;).

Now I cannot remember where we got this code but here it is. I hope it helps.

BTW, the package we use to compile this was gcc-mingw32.

$ i586-mingw32msvc-gcc sudo.c -o sudo.exe
# Put sudo.exe in /usr/bin or in your windows path (%homedrive%\windows)
$ sudo vi /cygdrive/c/windows/system32/drivers/etc/hosts

* (sudo for Windows™)
* @filename sudo.c
#ifndef UNICODE
#define UNICODE
#include <windows.h>
#include <shellapi.h>
#include <wchar.h>

LPWSTR *mergestrings(LPWSTR *left, LPCWSTR right)
    size_t size = ( 1 + lstrlen(*left) + lstrlen(right) ) * sizeof(LPWSTR*);
    if ( *left ) {
        LPWSTR leftcopy = _wcsdup(*left);
        *left = (LPWSTR)realloc(*left, size);
        *left = lstrcpy(*left, leftcopy);
        *left = lstrcat(*left, right);
        free( leftcopy );
        *left = _wcsdup(right);
    return left;

int WINAPI WinMain(HINSTANCE hInstance, HINSTANCE prevInstance, LPSTR lpcommand, int nShowCmd)
    DWORD result = 0x2a;
    LPWSTR *argv = NULL;
    int argc = 0;
    if ( argv = CommandLineToArgvW(GetCommandLineW(), &argc) ) {
        if ( argc < 2 ) {
            LPWSTR usagemsg = NULL;
            usagemsg = *mergestrings(&usagemsg, argv[0]);
            usagemsg = *mergestrings(&usagemsg, TEXT(" <command_to_run> [arguments]"));
            MessageBox(NULL, usagemsg, TEXT("Usage:"), MB_OK | MB_ICONEXCLAMATION );
            LocalFree( argv );
            free( usagemsg );
            return ERROR_BAD_ARGUMENTS;
        else {
            LPWSTR command = argv[1];
            LPWSTR arguments = NULL;
            int c;
            for ( c = 2; c < argc; c++ ) {
                arguments = *mergestrings(&arguments, argv[c]);
                arguments = *mergestrings(&arguments, TEXT(" "));
            result = (DWORD)ShellExecute(NULL, TEXT("runas"), command, arguments, NULL, SW_SHOWNORMAL);
            LocalFree( argv );
            if ( arguments )
                free( arguments );
            switch ( result )
                case 0:
                    result = ERROR_OUTOFMEMORY;

                case 27:
                case 31:
                    result = ERROR_NO_ASSOCIATION;

                case 28:
                case 29:
                case 30:
                    result = ERROR_DDE_FAIL;
                case 32:
                    result = ERROR_DLL_NOT_FOUND;
                    if ( result > 32 )
                        result = 0x2a;
        result = GetLastError();

    if (result != 0x2a) {
        LPWSTR errormsg = NULL;
                      NULL, result, 0, (LPWSTR)&errormsg, 0, NULL);
        MessageBox(NULL, errormsg, TEXT("Error:"), MB_OK | MB_ICONERROR);
        LocalFree( errormsg );
        return result;
        return NO_ERROR;
  • 6
    This code is awful. It's full of errors like not checking the return value of realloc() before dereferencing or writing sizeof(LPWSTR*) instead of sizeof(*LPWSTR) where LPWSTR seems to be a pointer type and one wants to retrieve the size of one character, not the size of the pointer. Furthermore, it's totally unclear why e.g. case 29 leads to ERROR_DDE_FAIL. Can you conclude from the code why? I can't and I guess anybody else can't, too. Please, do not post such code in the future.
    – user185282
    Jan 8, 2013 at 8:59
  • 4
    @Mattew: please in the future help the community by posting a cleaned up version of the code snippet you dislike. Jan 20, 2013 at 14:36
  • Code shouldn't be on superuser. Put it on codereview.se, and just link it from here.
    – Ben Voigt
    Apr 14, 2014 at 2:19
  • @user185282: Good points. I've downvoted the answer. Mar 20, 2017 at 3:28
  • Dear tao: You wrote, "I cannot remember where we got this code". Did you write this code, or did someone else write it? Mar 20, 2017 at 3:28

A slight improvement on Peon's fake sudo script:

# Drop any option arguments.
while [[ $# -ge 0 && $1 = -* ]]; do


This script silently drops any options passed to sudo and executes the command (without actually elevating the privileges). Dropping the options improves compatibility somewhat. A more complete wrapper script should actually parse options the same way sudo does.

Instead of trying to replace sudo with a wrapper that does cygstart --action=runas "$@", just use this simple fake sudo wrapper and run your install script itself (or whatever you're trying to run that uses sudo) with elevated privileges.


I've been using cygwin-sudo as a drop-in replacement for UNIX/Linux's sudo.

Based on the same principals but one can remain within your current window.


In scripts which can run on linux or windows (cygwin) you can alias out sudo in the script itself:

# Alias sudo to do nothing on windows
if ! $(type -P sudo) 
  shopt -s expand_aliases
  alias sudo=""

You can run sudo but may require options. If you know the user/group/ Active Dir environment you can supply those as options.

Here is a quick alias or you can "sudo" shell script in common PATH as previous example.

alias sudo='runas /noprofile /user:Administrator $@'  
alias sudo-='runas /profile /env /user:Administrator $@'

Before you can use "sudo" you need a running/enabled windows service called "seclogon".

cmd /c 'sc config seclogon start=auto'
cmd /c 'sc start seclogon'

or use powershell in following link: How do I enable services on a Windows computer via a command line?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .