When I wake up the computer and log in to it, Microsoft Edge starts automatically.

How can I stop this?


3 Answers 3


Unfortunately in 2022, the above method does not work... My current workaround is to run this bat on start:

timeout 1
taskkill /f /im msedge.exe

It will wait 1 second (or need to adjust to give time for Windows to complete the startup) and then kill edge.

To avoid showing the cmd dialog in a flash, either add this to taskschd.msc, or use a less perfect way but simpler to set property of this bat to run in minified screen.


The problem has occurred because you (or someone else) might have set up this app to run at startup...

To change Microsoft Edge from running at startup -

  1. Go to the search bar in your taskbar and type "Startup Apps"
  2. Click on the option labeled "Startup Apps"
  3. Click on the option
  4. Scroll down to see if there is Microsoft edge and the option is "on"
  5. Click on the option and turn it "off"

Now restart the computer to see if there are any changes


Avoid clicking on any text on login, but somewhere else on the screen. Otherwise it is interpreted as a request for a search of that text. Microsoft chose to ignore your default browser for that and selects Edge.

  • Welcoming you on Superuser, please refer this link superuser.com/help/how-to-answer . This will help you to maintain the quality of your answer. My suggestion is, to answer such question lots of research is required, also try to pass the KEY information. Commented May 22, 2018 at 10:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .