0

I am trying to enable root ssh login for a Solaris 10 VM (10.0.2.15) on a private netwrork. I have set PermitRootLogin to 'yes' in /etc/ssh/sshd_config as well as commenting out "CONSOLE" in /etc/default/login. I restarted the SSH service and then also reboot the VM because just restarting sshd did not seem to work.

From a Solaris 11 VM, when I try to login with the creds that work on the Console of the Solaris 10 VM, the login does not appear to work.

root@solaris11: ssh root@10.0.2.15
password:
password:
password:
Permission denied (gssapi-keyex,gssapi-with-mic,publickey,keyboard-interactive).

I have confirmed that the two hosts can see each other via ICMP "ping" exchanges and netcat:

root@solaris11: netcat -nvv 10.0.2.15 22
Connection to 10.0.2.15 22 port [tcp/*] succeeded!
SSH-2.0-Sun_SSH_2.2

What else I am missing to enable remote root login to this VM via ssh?

2
  • you restart sshd service, I assume this is a typo. You also allow passwordAUthentification yes ? – Archemar Jul 11 '17 at 14:00
  • Yes, thank you, I fixed the type. And yes I have passwords also enabled. I ended up creating a user account on both VMs with the same SSH keys and things work great in that respect. But the root ssh still does not work. – Dr. Watson Jul 13 '17 at 1:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.