0

This seems to be a common error, but none of the proposed solutions online worked.

The computer is an ASUS X556UB. The error is supposedly caused by Windows Update installing wrong drivers for the touchpad. I received the machine after the fact, I cannot see this driver in update history, so it could be that a lot of time passed since that.

The error symptoms:

  • Touchpad does not work.
  • Fn+F9 does not turn it on.
  • Touchpad is not listed under Device Manager/Mice and other pointing device
  • Something is listed under HID, called "I2C HID Device", and it has a little exclamation mark and an error message "A request for the HID descriptor failed".

The proposed solutions, that did not help, include:

  • Installing the latest drivers linked from the product page
    • ATK Package 1.0.0050
    • Asus Smart Gesture / Touchpad Driver 4.0.12
  • Installing the even latester drivers linked from a third-party page (the links still point to ASUS servers):
    • ATK Package 1.0.0053
    • Asus Smart Gesture / Touchpad Driver 4.0.18

What should I do to make my touchpad work again?

  • Did you try to update the I2C HID Device drivers using those of the touchpad? – spike_66 Jul 2 '17 at 6:24
  • You could also try to install the Synaptics Windows 10 I2C drivers: link – spike_66 Jul 2 '17 at 6:58
  • @spike_66 I managed to install the drivers from a subfolder called either Elan_PTP or Focaltech_PTP (the ones with I2C in the name didn't install). The error from the HID device disappears but the touchpad still doesn't work. – marczellm Jul 2 '17 at 10:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.