I got a broadband connection at home from GTPL . The guy set up the connection on laptop instead of router because I refused to buy a new router from the company.

Now the Internet runs fine (good results on SpeedTest) only on that specific laptop. If I put in the same credentials on a different laptop, it doesn’t connect. I get error 691 from win 7 and on xubuntu (15.04) the connection silently fails.

So my question is: Does PPPoE/my-cable-connection implement something like a “User-Agent” string? If so, how can I overcome it (spoofing?) and connect to Internet without submitting to ISP’s will? Because it’s really weird that the Internet works only on the machine that it was initially configured on.

  • 1
    This is most likely a MAC address issue. Meaning the MAC address of the laptop is associated with your account as well as the PPPoE credentials. The only way to solve this issue on a different machine is to either see if you can set up MAC address masquerading to copy the exact MAC address of the other laptop. Or get your ISP to associate your account with a router you have purchased that can then be used to connect any machine to your ISP. – Giacomo1968 Jul 2 '17 at 4:33

PPPoE is Ethernet encapsulated over PPP - it has no concept of a User-Agent string or web browser. It is likely to do with the PPP options - there are a fairly large number of tweeks, variants and options in PPP - If you are able to look at the log files it may give you some clues.

Some more likely candidates to check out are PAP vs CHAP vs MSCHAP vs MSCHAPv2 authentication, compression, requiring peer authentication, encryption.

(I would be surprised if the problem has to do with MAC addresses, although it is conceivable)

  • I meant something like user agent, I know that only browsers use it. Anyway how do I generate logs on that working laptop so I can mimic it elsewhere – RinkyPinku Jul 2 '17 at 9:13
  • Sorry, no idea - I've not set up PPPoe on a Windows box in years (if ever). – davidgo Jul 2 '17 at 9:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.