0

I have this problem with my PC. I tried using complete internet repair, completely scanned malware and adware (all clean now) and Kaspersky is currently running but still I cant access the internet on any browser or other applications - however I can ping websites like Google.

tried the winsock reset still no luck, uninstalled the network driver and restarted still the same. After some time, Mozilla gives up connecting it says "Secure Connection Failed".

Ok now I have decided to reset my windows 10, my applications were deleted but still I cant access the internet. I'm losing hope, maybe the nic is bad?

Update: I have double checked my cables using my rj45 tester, all seems to connect but the problem still persists.

Date and Time is set but still cant access

0

Are you able to use internet on any other device at your home?

If you are able to ping google it means internet is working fine. But you are unable to access internet. In that condition, problem would be with browsers so use Internet explore or Edge(on windows 10) to cross check.

Or you can reset the Mozilla firefox too. TO reset Firefox. Click help on menu bar -> then Troubleshooting Information -> then Refresh Firefox.

If still facing issue then try rebooting your modem/router and pc then check.

ipconfig /release

ipconfig /flushdns

ipconfig /registerdns

If any of these solutions not working for you. Then there might be some conflict with software, driver or security software. You can try to restore your pc to the last working stage before going to windows reset/refresh.

  • it seems so the internet is fine, its not only the browsers who cant access the internet but all of my applications, my anti virus cant update, steam is offline etc. I have cleared all the history, temporary files etc. still the same, Thank you for responding btw – Jpir Jul 2 '17 at 9:29
  • Are any proxies configured? – Hennes Jul 2 '17 at 9:57
  • also tried the updated fixes, still didnt work, I have already made reset on my pc and still the problem persist. – Jpir Jul 2 '17 at 10:14
  • and no proxies, I haven't configured any – Jpir Jul 2 '17 at 10:15
  • Great News! :D your fix with ipconfig /release ipconfig /flushdns ipconfig /registerdns worked after I restarted the pc, I wonder what caused this kind of trouble, Thank you! :) – Jpir Jul 2 '17 at 11:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.