14

Microsoft offers these downloadable virtual machine images for cross-browser testing (IE8-IE11 and Edge). My host OS is Ubuntu 16.04 (64-bit) and I'm running Virtualbox 5.0.40_Ubuntu r115130.

The problem I experience is that loading two of the images Win10 stable and also the Win10 preview (after having successfully imported the appliances) gets stuck at the start screen. My host OS shows one CPU core fully utilized, so it's likely a CPU bottleneck, right?

enter image description here

After about a quarter of an hour, still no progress here.

At importing the appliance I left everything as it was preconfigured (4096MB memory, 1 CPU, etc.). Is there any "trick" to overcome this?

23

I have had the same problem.

I fixed it by changing the Virtualbox Setting -> System -> Acceleration -> Paravirtualization Interface and selecting KVM instead of "default".

Now boot Window 10 again and it should boot.

You may select "none" but the performance is so much slower.

FYI: I have the same version of virtualbox 5.0.40_Ubuntu r115130 and upgraded to windows 10 1709.

  • I tried everything possible with no luck, then I found this comment... Never even would have though it was the hypervisor in this case... Thanks for saving me another 5 hours of struggle. – Ethode Dec 9 '17 at 22:40
  • 1
    Yes, thanks for taking the time to record this is has saved me a lot of hassle. Does anyone know what this setting actually does - jFTR? – diversemix Dec 17 '17 at 21:53
  • I had the same problem and it actually worked. Changed to KVM and now its booting up properly. – Dawid Pura Mar 22 '18 at 6:48
  • This did it for me too, massive help! – Michael Mallett Oct 21 '18 at 3:36
3

I had a similar problem. I'm running Linux Mint 18.1 x64 (based off 16.04 Xenial) and VirtualBox 5.0.32. I have a full/real version (not the IE tester version) of Windows 10 that was running fine in VB as installed from the ISO. This was version 1511 (build 10586).

I then tried to update to version 1703 (build 15063) and experienced exactly the same behaviour that you've described. The solution for me was to update the version of VirtualBox to 5.1.22, the latest at the time of writing. 5.0.32 was the latest available in the Ubuntu repository so I had to install the newer version from the VirtualBox apt repo as described at https://www.virtualbox.org/wiki/Linux_Downloads#Debian-basedLinuxdistributions:

Add the following line to your /etc/apt/sources.list:

deb http://download.virtualbox.org/virtualbox/debian yakkety contrib

According to your distribution, replace 'yakkety' by 'xenial', 'vivid', 'utopic', 'trusty', 'raring', 'quantal', 'precise', 'lucid', 'jessie', 'wheezy', or 'squeeze'. ... The Oracle public key for apt-secure can be downloaded...and register[ed]:

wget -q https://www.virtualbox.org/download/oracle_vbox_2016.asc -O- | sudo apt-key add -
wget -q https://www.virtualbox.org/download/oracle_vbox.asc -O- | sudo apt-key add -

...snip...

To install VirtualBox, do

sudo apt-get update
sudo apt-get install virtualbox-5.1

...snip...

Note: Ubuntu/Debian users might want to install the dkms package...through the following command:

sudo apt-get install dkms

Once I updated VirtualBox, I performed the update in the guest and after restart I almost instantly saw the white dot spinner appear on the black screen with the cyan windows logo (that you've attached) as you'd expect.

  • Would it be best to remove your existing Ubuntu-distributed VirtualBox installation before performing this procedure, or will this upgrade it? Or can you run them in parallel? Will your existing configurations be maintained? – k-den Aug 16 '17 at 18:46
  • I tried these steps without removing the existing Ubuntu-distributed VirtualBox, and now when I try to open the Win 10 image previously imported it says "RTR3InitEx failed with rc=-1912 The VirtualBox kernel modules do not match this version of VirtualBox. The installation of VirtualBox was apparently not successful. Executing '/sbin/vboxconfig' may correct this. Make sure that you do not mix the OSE version and the PUEL version of VirtualBox..." Executing /sbin/vboxconfig did not fix it. – k-den Aug 16 '17 at 18:58
  • @k-den I think apt should perform an upgrade and keep all your settings, at least that's what happened to me. As you're running into trouble, it might be best to backup the virtualbox config (have to Google where that lives) the apt-get purge all versions of virtualbox from your system, then install a fresh copy. Alternatively, you might just have to restart your system if it hasn't picked up the new kernel modules. – Tom Saleeba Aug 17 '17 at 0:34
0

I had this issue too. I got it working by updating Virtualbox to version 5.0.40 and changing the general settings tab to other for both type and version.

$sudo apt autoremove --purge virtualbox*
$sudo apt install virtualbox=5.0.40-dfsg-0ubuntu1.16.04.1

Name: Windows 10
Type: Other
Version: Other/Unknown(64-bit)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.