0

So, here's what happened. I plugged in a bootable W10 installation thumbdrive. After deleting two preexisting partitions that I had made manually, the installer created a reserved system partition (partition 0), and a normal storage partition (partition 1). After this, it began installing Windows 10 on the HDD. However, it was stuck on 0% on "Preparing files for installation." Because of this, I exited setup, and tried the process again. After I selected the Custom installation, I see "Drive 0 Partition 1: System Reserved," and "Drive 0 Partition 2." I tried installing it on the second partition, but it brought up the error message, Windows could not format a partition on disk 0. The error occurred while preparing the partition selected for installation. Error Code 0x80070057.

After this, I tried restarting the installation, and format the partition with the UI format button. The following error message occurs: We couldn't format the selected partition. [Error: 0x80070057].

After this, I tried to format both partitions with Diskpart. Both times, I was told that it couldn't be done because of an I/O error. When I tried to clear the disk and each of a partitions, it would happen again. Is there any way to fix these errors and install Windows?

  • Do you have UEFI bios? What's your HDD partition style, MBR or GPT? – Biswapriyo Jul 2 '17 at 12:37
  • I believe I use EUFI, but I'm not sure about MBR or GPT. – Jose' Pepper Jul 2 '17 at 13:46
1

Googling the error message turns up this Microsoft page that claims the error is caused by a bad pre-existing filesystem on the partition, and that the solution is to completely delete the partition and re-create it.

If you have problems even with that, I have two additional suggestions:

  • Use another OS -- Whatever is giving Windows fits might not affect another OS. For instance, you could use an Ubuntu Linux installation disk, booted in its "try before installing" mode. You could use that to run GParted to re-partition the disk and prepare filesystems on it. Since the Linux tools don't share code with the Windows tools, they might not be affected by the Windows glitch.
  • Completely wipe the disk -- You could completely zero out the disk. This will likely take several hours. See this question and its answers for pointers to utilities that will do this. With nothing but "0" values on the disk, no utility should be confused when trying to partition and format the disk.
  • Hi, Rod. I appreciate the reply. The thing is, I only have one flash drive, and it was a miracle that my unreliable internet stayed up long enough to download windows 10 and write it to the flash drive (I used the media creation tool.) Is there any way I could wipe the disk with command prompt, or would I get a similar result? – Jose' Pepper Jul 2 '17 at 13:49
  • 1
    See the 3rd link in his answer. – Biswapriyo Jul 2 '17 at 17:08
  • Alright, I've worked out, it's nothing to do with Windows. While trying to install Ubuntu, I was given a similar error message. While trying to use DBAN, it didn't recognize the HDD at all. – Jose' Pepper Jul 3 '17 at 1:22
  • That sounds like a hardware failure, then. :( – Rod Smith Jul 3 '17 at 14:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.