I have a Microsoft Exchange account configured in Outlook 2010. I'll be getting multiple pop ups saying that "Outlook is retrieving data from the Microsoft Exchange Server" in tray.

Mails won't move or will move slowly to local PST, and Outlook crashes fairly often.

  • There are too many factors to consider why this is moving slow for you so edit your question and add details such as your Outlook profile setup, your network configuration such as accessing the Exchange Server via slow WAN link, etc. You detail seems to vague for someone to give you an answer and there are just so many reasons for what could cause the slow connection from the MAPI client to the email server. If you're not the Exchange admin, the network admin, or the PC support guy, then ask those that are to start with as they should understand your environment. Jul 3, 2017 at 11:36
  • Actually I had contacted my IT support team , still they have no resolution . My profile setup is fine , is there a possibility that exchange admin has reduced the bandwidth /download speed and that might be causing this ??
    – Sven
    Jul 3, 2017 at 11:42
  • Does the Exchange Server and the PC where the Outlook connects to it on the same subnet? Ping the Exchange server, look at the IP address, and then do an IPCONFIG from an elevated command prompt and see if that IP is on the same subnet range as the email server. How is your Outlook profile configured exactly, and in the account setup setting? I'm sure there's a way to throttle bandwidth or whatever at the Exchange level and there could be QOS at a router levels doing this as well so there are many reasons and that could be only two of them but it's a guessing game without facts. Jul 3, 2017 at 11:53
  • This issue has narrowed down to network issues and my IT team are looking towards improving it , thanks McDonalds
    – Sven
    Jul 6, 2017 at 7:55

2 Answers 2


According to Microsoft Support, this is a known issue when upgrading from Outlook 2007 or earlier to Outlook 2010 or 2013.

Resolve the issue by installing update 2825677 (Outlook 2013) or 2598374 (Outlook 2010)


When you use RPC time-out registry entries or policies in Microsoft Office Outlook 2007 or in an earlier version of Outlook, and then you upgrade to Outlook 2013 or Outlook 2010, you receive the following message in the taskbar:

Outlook is retrieving data from the Microsoft Exchange Server Server_Name.


To resolve this issue for Outlook 2013, apply the following update:
  2825677 Description of the Outlook 2013 hotfix package: October 16, 2013

To resolve this issue in Outlook 2010, apply the following update:
  2598374 Description of the Outlook 2010 hotfix package (Outlook-x-none.msp): June 26, 2012

Registry Key Information

[...] After you install the hotfix package, to have us enable the hotfix for you, go to the "Fix it for me" section. If you prefer to enable the hotfix yourself, go to the "Let me fix it myself" section.

Fix it for me

To enable the hotfix automatically, click the Fix it button or link. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.

Let me fix it myself

After you install the hotfix package, follow these steps to enable the hotfix:

  1. Start Registry Editor. To do this, use one of the following procedures, as appropriate for your version of Windows.

    • Windows 8: Press ⊞ Win + R to open a Run dialog box. Type regedit.exe and then press OK.
    • Windows 7: Click Start, type regedit.exe in the search box, and then press Enter.
  2. Locate and then select the following registry subkey:


Note The x.0 placeholder represents your version of Office (15.0 = Office 2013, 14.0 = Office 2010).

  1. On the Edit menu, point to New, click Key.

  2. Type RPC, and then press Enter.

  3. Locate and then select the following registry subkey:


Note The x.0 placeholder represents your version of Office (15.0 = Office 2013, 14.0 = Office 2010).

  1. On the Edit menu, point to New, and then click DWORD (32-bit) Value.

  2. Type TimeToShowRPCMessage, and then press Enter.

  3. In the Details pane, right-click TimeToShowRPCMessage, and then click Modify.

  4. In the Value data box, type the number of milliseconds as you prefer, and then click OK.

Note The default value is 10000, which equals 10 seconds. For more information about determining how you should configure this, see the "More Information" section.

  1. Exit Registry Editor.

Adapted from Microsoft Support: "Outlook is retrieving data from the Microsoft Exchange Server" message after you upgrade to Outlook 2010 or Outlook 2013


Microsoft Outlook 2013.

I've had the same problem ever since our IT team launched a recent Windows update. It's been slowing me down for about a month. I've tried many of the tips found on various forums and they either didn't work for me or only solved the problem for a day or so. My only option was to send my computer in for a complete rebuild which I couldn't do with the amount of downtime involved and inconvenience. Out of desperation I simply tried the Outlook built in repair function. It worked! File>Account Settings on the Email tab there are 6 icons. The 2nd one is "Repair". I clicked on it and for some reason the problem got fixed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .