0

Normally, on a day-to-day basis I use a non-admin account in Windows 7 for nearly everything. I think I log fully in as admin less than once a month. I do make use of "run as administrator", however, and always enter admin credentials when installing software. This has worked fine for me since I started using Windows 7 several years ago, until I tried to install this program:

http://povray.org/download/

It does not prompt me for admin credentials during installation, and thus fails. When I try to "run as administrator", the program installs correctly, but the modifiable user files are locked in the administrator's Documents directory.

How can I install this program so it is usable by my non-admin account? Also, how might the software itself be changed so that it properly installs for non-admins?

Thanks.

1

First of all, I applaud you for using only a limited account instead of an admin account on a regular basis. If you're not making a living off of repairing computers or removing malware, you shouldn't be using an admin account regularly.

It does not prompt me for admin credentials during installation, and thus fails.

I believe that you can install POV outside of the Program Files* directories, so you can install the program in: %USERPROFILE%\POV-Ray\ and it should work, (any directory in your user profile should work as well, but I recommend installing it into its own folder to prevent issues with other programs). Really, any folder that you can create folders and files in will work as well.

As for the files locked in the Administrator's folder, why not just copy the files into your home folder while logged in as an administrator and then grant yourself full access to the files?

I haven't installed POV-Ray in a while, but running the installer gives me the option to change the install path, so I'm pretty sure at least one of the above methods will work for you. Currently I don't need it; so I'm not going to fully install it.

| improve this answer | |
  • I don't think it's a good idea to install outside of Program Files, but the second suggestion works. I just wish the program had signaled that it needed admin privileges to install instead of just failing. It would have saved me a lot of time. – posfan12 Jul 6 '17 at 4:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.