This question is pretty specific, but I hope someone will have seen this error elsewhere. I am configuring a machine running OS X 10.5.8 to be an NTP server for machines connected to a LAN that is not connected to the Internet. I am not too worried about knowing the "right" time on all the machines, but rather worried about making sure everyone has the same notion of time.

I configured the NTP daemon on Mac by turning on the Set date and time automatically in System Preferences, using the server's clock, as the reference clock. I figured I should see if the server can NTP query itself before proceeding to the clients.

The weird part is when I run the ntpq -p command in a command-prompt when connected to my D-Link DIR-655 (firmware: 1.33), it hangs for about a minute or so each time before finally giving me some output. I thought the problem might have to do with Port Forwarding, so I configured the router to forward port 123 for the IP of the server, but that did not improve the situation.

When I run the ntpq -p command on my school's network, on a Linksys WRT54G router, or with the wireless Airport card turned off - I have absolutely no problems - the command returns a response instantly.

Is this normal? I can see why a query might take a minute or so, but I don't understand why one router does it faster than the other.

I tried messing around with the ntp.conf file adding the burst, minpoll, and maxpoll options:

server burst minpoll 4 maxpoll 5

Figuring that perhaps I am polling too often and the configuration file is slowing me down, but even with this, the ntpq still hangs on the D-Link DIR-655, but does just fine on the other routers.

Any thoughts on where the lag is coming from or if the lag is even a problem?


So you're saying that when your Mac is associated to the D-Link box, and run ntpq -p on your Mac, that it hangs? But the same command doesn't hang when your Mac is connected to the Internet other ways, or via other wireless gateways?

Next time you're associated to the D-Link, do an ipconfig getpacket en1 and see if the D-Link's DHCP server is returning a time server option in the list of DHCP options.

If the D-Link's NTP client is enabled, and you can disable it, consider disabling it and see if that makes a difference.

Try running tcpdump -i en1 -vns0 port 123 or arp or icmp to see what happens NTP-wise (and ARP- and ICMP-wise) on the network when you issue your ntpq -p command.

Look at /var/log/system.log for any interesting messages from ntpd.


Just a guess: Perhaps name lookups are slow? Try ntpq -pn (option n disables name lookups).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.