0

I have set up RasPBX on a Raspberry Pi 1 using chan_mobile to forward calls to and from a mobile phone to a SIP client using the both the instructions for plain Asterisk here and via FreePBX here. In both cases outgoing calls (from SIP client via mobile) work fine but on incoming calls (to mobile forwarded to SIP client) the caller can hear the receiver but the receiver cannot hear the caller.

A found a post with a similar issue that suggested to force USB to 1.1 using the dwc_otg.speed=1 boot option but that didn't work as my case is different in that the issue only happens on incoming calls.

How can I diagnose and fix this?

2
  • I have the same problem with: dslreports.com/forum/r30661088-PBX-FreePBX-for-the-Raspberry-Pi when using Asterisk 13 or Asterisk 14. There is NO problem if Asterisk 11 is used. This leads me to believe the problem is with Asterisk 13/14, but I've been unsuccessful at getting Digium to investigate it.
    – RonR
    Jul 8, 2017 at 20:54
  • Thanks for the tip. I worked around the problem by downgrading to Asterisk 11.
    – glennr
    Jul 11, 2017 at 3:18

1 Answer 1

-2

Fix No audio inbound Chan_Mobile !!!!..

EXSTENSIONS_CUSTUM.CONF [A12] exten => _X.,1,Dial(Mobile/A12/${EXTEN},45) _X.,n,Hangup [incoming-mobile] exten => s,1,Noop(Entering macro-from-mobile-custom-1 with DID = ${DID} and setting to: 0123) exten => s,n,Set(__FROM_DID=0123) exten => s,n,Goto(from-trunk,0123,1)-Mobile]

MAKE DID NUMBER 0123 point to Queue and if you don't an send it to extensions you get no audio

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.