13

My laptop is set to go to sleep when not in use, but when I have it set to use Dual screens, after I "wake it up", all I can see is the mouse on the second screen, flickering. If I unplug the VGA cable, the laptop screen wakes up, and I can see the log-in screen. Once I plug the VGA cable back in, the second screen "wakes up" too.

This problem does not occur on startup, and I have set the second screen to be my main display - but I do often disconnect the laptop to take it with me. I have also changed the settings to make the laptop screen my main display, and the issue still occurs, just on the laptop screen instead.

This has only just started happening, around the time of the last update (2017-06 Cumulative Update for Windows 10 Version 1607 for x64-based Systems (KB4022715)).

Running Windows 10 Home, Acer Aspire E 15. Let mem know if additional information is required.

16

I had a similar issue with one of my dual monitors not showing up after resuming from sleep. I used the keyboard shortcut Ctrl+Shift+Win+B to restart the graphics driver and my main screen flickered off and then both screens turned on.

There's some more information in this question.

| improve this answer | |
  • Great! It works for me. – Sergеу Isupov Aug 29 '19 at 5:04
  • In fact, it worked only once – Sergеу Isupov Aug 31 '19 at 18:38
  • I've installed graphic driver. But after restart, my second monitor is turned off whenever lockscreen appear on primary screen. – quangkid Apr 28 at 3:08
  • Did not work for me. Had to reboot. – sobelito 22 hours ago
1

Perhaps it'll be useful to anyone:

My unit is old Fujitsu P710, fairly standard business aimed, core i3 based pc. BIOS: Aptio Setup Utility | Code ver. 4.6.5.3

I fixed the issue with secondary monitor not waking up after exiting sleep mode by changing bios settings:

Go to Power tab: change "Hibernate like Soft OFF" value to disabled.

Save & exit.

That's it. Problem went away in my case.

| improve this answer | |
  • Welcome to Super User! Please do not post the same answer to multiple questions. If the same information really answers both questions, then one question (usually the newer one) should be closed as a duplicate of the other. You can indicate this by voting to close it as a duplicate or, if you don't have enough reputation for that, raise a flag to indicate that it's a duplicate. Otherwise tailor your answer to this question and don't just paste the same answer in multiple places. – DavidPostill Jan 4 at 16:17
0

Here are some troubleshooting steps that may help in solving that issue.

  • Open Power Option and click on Change plan settings then Change advanced power settings.
  • Expand Hard disk then Turn off hard disk after and set it to Never.
  • Expand Allow hybrid sleep and set it to Never, set Hibernate after to Never as well.
  • On Power Option main menu, on the left pane click on Change what the power buttons do.
  • Once open under Shutdown settings remove the check on Turn on fast startup then click Save changes.
  • Also do disable the screen saver mode of your PC when it idles.
  • Next is to do a clean install of your graphics card driver as well.
  • Please do follow the guide in this article on how to do a clean install of your GPU driver. http://www.tomshardware.com/faq/id-2767677/clean-graphics-driver-install-windows.html
| improve this answer | |
  • I've done all but the fresh install of the GPU, and the problem is still occurring. It also appears that the windows update system is trying to install the same driver, over and over. So I'll try the fresh install and see what happens. – Ben Jul 7 '17 at 3:25
0

I have a PC with dual monitors and use the latest version of win10. I have increasingly had issues with the graphics side since upgrading to win 10, most I have lived with or overcome to a certain extent. My latest issue has been related to sleep mode start up, without going into too much detail this was overcome by changing from sleep to hibernation. Now the PC is in hibernation mode the 2nd monitor will not wake up until I restart the PC. I don't like to be beaten and have spent a lot of time going around in circles, the PC was a high end spec when built in 2011 but the root of the problems are due to the graphics chipset on the mobo do not support win 10. It's not obvious until I contacted asrock who confirmed this. The PC still works well when running but I am going to change the mobo for one that supports win10. In summary if something in your PC/laptop is not compatible with the latest win10 update you can spend a lot of time chasing your tail until you hit a brick wall. Hope this helps. Update - have changed motherboard to one with a Win10 compatible chipset and the problem has disappeared.

| improve this answer | |
0

I have yet to locate the solution to this issue, but an easier work-around than rebooting is to switch your display to mirror mode. This wakes the second monitor immediately, and then simply click revert in the "are you sure" popup to get back to your desired setting. Its still annoying, but this is a faster way to get thru it in the meantime.

| improve this answer | |
0

ati radeon HD 3850 does work with 2 screens but screen 2 doesn't start after sleep. Workaround. Screen settings, copy screen change into extend screen. (Screen will wake up) revert the setting to either extend or copy This works in a AMD 64 win 10 with fall update problem. screens are Acer AL1916w and Neovo 17e My setup worked flawless with w10 64 amd processor and hd3850 but after fall update recently...neovo e-17 screen keeps in standby (yellow light) only wakes up when change settings from extend to copy or visa versa. Problem is Windows update. But here is my workaround.

| improve this answer | |
  • If your system is equipped with an AMD Radeon™ HD 4000 Series product or older, you may consider the following options: Continue using the existing operating system.​ If you have already upgraded to Windows® 10 and would like to revert back to the previous version of Windows, refer to this Microsoft page for instructions. Upgrade to an AMD graphics product that provides Windows® 10 support. For information about resellers and product availability, visit: shop.amd.com NOTE: Before upgrading ensure that your system meets the requirements of the graphics adapter, such as: – user869236 Feb 4 '18 at 8:44
  • continued: Motherboard with compatible graphics card slot Adequate power supply unit to handle the complete system power requirements Display with compatible connections – user869236 Feb 4 '18 at 8:45
  • Products That Do Not Support Windows® 10 AMD Radeon™ HD 4000 Series products and older are not certified to support Windows Display Driver Model (WDDM) 1.2 or higher and therefore, do not have driver support for Windows® 10. The following is a list of graphics products that do not support Windows® 10: support.amd.com/en-us/kb-articles/Pages/… – user869236 Feb 4 '18 at 8:46
0

I found a simple solution I make sure that no monitor is using VGA. It seems that Windows 10 will "wake up" the Digital Monitor (HDMI/DVI/DP) but not VGA. I have had to remove the VGA connection on countless users computers to get around the problem.

I have tried to use the DP to VGA, HDMI to VGA and DVI to VGA converters but that does not seem to solve the problem. The monitor works correctly with DVI to HDMI, mini DP to DVI and DP to DVI.

| improve this answer | |
  • Welcome to Super User. Just a guess, but the OP probably would not be using VGA if those other connections were possible. :-) – fixer1234 Jul 12 '19 at 5:58
  • I'm encountering this issue with a VGA cable plugged into a DisplayPort with an adapter, so you might be onto something. – MonsieurPoivron Feb 24 at 9:55
0

disabling the display driver that is not working and enabling again in the device manger worked for me . it caused my screen to flicker for 1 time but it worked .

hope it helps

have been searching all over in the net for answers.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.