2

Basically trying to move Windows installation from one drive to another (HDD -> SSD). Already had a Linux partition on SSD, so didn't want to reformat/clone over the SSD.

Copied the C: drive to SSD, and have now been around and around the recovery environment trying to move ESP to SSD. I now seem to have two copies of the ESP, one on old HDD which successfully boots original C: partition, and has at times booted new copy (labelled D:) - disk management console shows D: is system, primary, boot, ... whilst C: only primary in this case.

New ESP fails to boot copied drive when old HDD removed. Black screen appears after the Windows loading screen and moving the mouse brings a cursor up which disappears after a couple of seconds not being moved. Continuous movement keeps cursor active but it resets to the centre of the screen (jumps) every few seconds. This happens in both safe mode and normal boot (setting safemode with bcdedit /set {default} safeboot network or similar).

If both drives are connected, then bootrec /scanos shows the C: partition as possible to add (this is on the HDD). At present, bootrec /fixboot gives an error message reading Cannot find file specified when both are connected. In the past this command has worked (as in, executed) but I've not managed to boot from the SSD without the HDD connected.

Any thoughts (preferably beyond 'reformat SSD and restore from backup that you create before/after via the booting old partition and ESP')?

Edit: as a somewhat curious point, when I boot to black screen plus cursor, I can access the computer remotely using Teamviewer. I still only get a black screen, but it's definitely doing something. It loads Teamviewer as a service though, so it's still before login.

  • Possible solutions: windowsreport and drivereasy – Sam Jul 6 '17 at 8:37
  • I've taken a pass at most of the suggestions on the first link - removed second screen, checked BIOS updates, uninstalled driver, reinstalled driver (I'm not sure this is the problem given safemode is the same, but tried anyway). Don't have an output for integrated graphics, and the BIOS setting explicitly sets the graphics output - checked this against the System Information panel, just in case. The second link seems to mostly require booting into the OS in question, which I can't - I can only boot to the old version which I'm hoping is functionally separate. – chrisb2244 Jul 6 '17 at 8:45
0

This is just a guess, but from winpe you could try the following (with C being whichever volume letter has windows and S being the system partition)

bcdboot C:\Windows /s S:

Also, is it formatted to the right filesystem type?

  • Thanks for the suggestion. I've tried this a couple of times with both the C drive (when only SSD connected) and D or C (with both), but again copying to the "new" ESP. – chrisb2244 Jul 6 '17 at 23:35
0

I fixed this (sort of - using my not-preferred approach) by creating a System Backup using AOMEI Backupper Standard to another HDD, then using the Windows PE USB to reinstall Windows 10 onto the SSD.

This means I'll have to put the Linux installation back on after, which is annoying, but after a day and a half of restarting over and over I was out of patience and need to get on with things.

I then used AOMEI in 'Restart Mode' by booting to the new Windows, and trying to restore from the System Backup. I chose NOT to use System Restore, instead taking only the C: drive from the backup, and overwriting the (new) C: drive on the SSD.

Following this, the partition wouldn't boot, but I now had a working Recovery partition. This allowed me to get the Command Line open easily in the Recovery Tools, where I used BCDEdit after assigning drive letters using DiskPart.

I observed that the device and osdevice fields shown by bcdedit were 'unknown'. I then used

bcdedit /set {default} device partition=C:
bcdedit /set {default} osdevice partition=C:

to set those to a good value.

I didn't need to use bootrec, or bcdboot to rebuild the ESP, and I had carefully not overwritten it when restoring the partition for the C: drive.

On the next boot, everything worked properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.