180

in Windows XP, when I type an apostrophe ', or dumb/typewriter quote ", no character is displayed. If I type another character, the apostrophe or dumb quote and the next character appear at the same time. This happens with double quotes ", apostrophes ' and tilde ~ characters.

What could possibly be causing this?

This occurs in all applications I have tested - wordpad, firefox, ms word etc.

4
  • Duplicate of this question.
    – JdeBP
    May 24, 2011 at 17:01
  • 6
    United States-International keyboard was the problem for me. Had to remove it from Control Panel\Clock, Language, and Region\Language-->options and keep US in Input method.. This solve this issue in windows 10 as well .. source from ojnetworks.com.au/2012/04/…
    – Aravinda
    Feb 1, 2016 at 4:16
  • 2
    Windows 10 Users: See antreality's comment on Gabriel's answer below for a fix for this OS
    – Deleted
    Feb 19, 2017 at 3:34
  • I'm having a weird problem where PowerPoint 2013 in Windows sometimes treats my apostrophe key (single-quote) as a comma and even more often as an open curly single-quote (instead of as an apostrophe). It's driving me crazy. I've checked my Windows keyboard settings and don't see anything abnormal.
    – Ryan
    Feb 27, 2018 at 15:55

12 Answers 12

71

Edit: since people are complaining that this answer does only answer the "Why" question, and does not provide a solution to the problem (which wasn't the question asked by the OP), please find the solution to the problem in the next answer https://superuser.com/a/343483

This is because you have a keyboard where ' ~ " are set to be a dead-key.

The behaviour of a dead key is ... well... to be dead! So no reaction when you press it.

A dead key is gonna be waiting for the next key to be pressed, to alter what that key is gonna print. For example ' + a might produce á if the quote key is configured as a dead key.

Usually, when a keystroke has no meaning after a dead key, it defaults to printing the character of the dead key, followed by the new character that has been typed.

So you can follow advice of other posters on how to change your keyboard (look at which KB you have configured). You can also get the Microsoft Keyboard Layout Creator to map a new keyboard and see how you can program dead keys.

Update: with the keyboard editor, you can also load the current keyboard and modify the dead key setting

1
  • 1
    MSKLC hasn't been updated in over 2 years, and requires .NET Framework 3.5 which I'm not going to install on Windows 11 just for this app. Not an option anymore IMO. Looks like a dead app.
    – Neo
    Aug 21, 2022 at 11:13
266

The reason is because you are using US-international keyboard.

Here is how to change this:

  1. In the Windows run box (Windows+R) type control intl.cpl or control international.
  2. Click the "Keyboards and Languages" tab
  3. Click "Change Keyboards..."
  4. AT THIS POINT MAKE SURE YOU ARE USING "English (United Kingdom) - US" as the default input language, meaning you set the keyboard to US, not US-international
14
  • 4
    be aware however about the differences of the International, the US, and the British English keyboard layouts.
    – n611x007
    Sep 5, 2013 at 15:54
  • 2
    this doesnt work on win 8.
    – numan
    May 1, 2014 at 14:00
  • 4
    Thanks! On Windows 8.1 I had to press Start, then search for "Edit language and keyboard options". The words are a bit different to Win7 / XP but its the same approach
    – will-hart
    Jun 4, 2014 at 21:28
  • 1
    This is the correct answer. "English (United Kingdom)" as the language and "US" as the keyboard. Works with Logitech TK820
    – Derek
    Sep 12, 2014 at 8:13
  • 31
    For Windows 10, the fix from control panel did not work. I have to use "Settings" -> "Region & Language". Then, selecting on the language -- in my case, EN(UK) -- gave me the options button to go to "Language Options" where Keyboards can be changed; in my case, add "US-Qwerty" and remove "US-Intl".
    – antreality
    Nov 23, 2016 at 21:52
19

I checked my settings and they are set to English/US but the problem persisted. Then after closing the dialogue an icon appeared on the task bar allowing me to change from EN/International keyboard to EN/US Keyboard - Problem fixed!

1
  • Exact reason for my pc too. Thank you
    – Duke
    Jul 9, 2023 at 12:09
11

The problems lies in the Input Language. To change between Input Languages, press Left Alt+Shift. This should solve your problem. If this doesn't work, do it this way:

  1. Search for Language in the Start menu
  2. Click Change keyboards or other input methods
  3. Click the Keyboards and Languages tab
  4. Click Change Keyboards...
  5. Click the Advanced Key Settings tab
  6. Click Change Key Sequence
  7. Assign a shortcut to Switch Input Language
1
  • 2
    I have to press WIN+SPACE to switch languages Jan 16, 2016 at 13:16
8

Check your keyboard settings in Region/Language. If it is set to non-English/US it may be expecting accented characters, formed by pressing the accent (', ", ^, etc) and then a character.

6

I experienced the same annoying problem since the fresh and clean install of Windows 7 a few months ago. It turned out, that during the installation of the additional input language, Windows has added Ink Correction. This is a keyboard service for "easy" entering of accented characters.

The solution is to remove this Ink Correction:

Text Services and Input Languages

And don't forget to restart the Windows after you removed the Ink Correction.

EDIT:

Removing the Ink Correction fixed the problem only partially. (The dead-keys were gone in the Skype chat, but were still dead in Word 2010.)

Final Solution: Change the input language United States-International to US.

5

I had the same problem too. My ' "keys were not working on the first stroke. I changed the input language to English(United kingdom) United states international to English(United kingdom) US. My keyboard is now working perfectly.

5

As others have mentioned, this is because the keyboard layout gets set to "United States International". I faced this issue when setting up a new Windows 11 PC.

On Windows 11,

  1. Search "Language and Region" in the start menu
  2. Click the "Meatball" menu next to the current language setting Where to click
  3. Click "Add a Keyboard" and select "US" instead of "United States International" (or the appropriate keyboard layout for your region). US instead of United States International
1
  • I just edited someone elses answer to show these steps, only to scroll down and find this answer which is what I did on Windows 11 to resolve the issue. +1 thank you.
    – Phill
    Jul 19, 2022 at 7:50
1

Windows 10 in 2021:

Go to Settings and select Devices: enter image description here

Scroll to Typing and select Advanced Keyboard Settings:

enter image description here

Pick something other than United States-International:

enter image description here

0

On Windows 10, the simplest and only working solution i found was to remove the keyboard shortcut that caused the mess in the first place from Control panel \ Clock, language and country / region \ Language \ Advanced Settings

The 28 MB English (US) input language pack and language bar visibility settings were not needed.

0

Using Windows 10

I found that my language pack was associated with a keyboard that provided this behaviour instead of the behaviour that I wanted.

  1. In the bottom right of your screen (task bar) there is a symbol showing your language. For me it is ENG
  2. Click on that, select 'Language Preference'
  3. Click on the language, choose 'Options'
  4. Add the keyboard you want, and delete the one you don't. I changed the Keyboard to 'US QWERTY' and now I don't have 'dead' keys or whatever they are called
0

In Linux there is a keyboard layout "USA International (AltGr dead keys)" which only has the dead keys when you hold the AltGr key. So the ' and " etc work as normal, but when you press them while holding AltGr, then they become dead keys.

There is a custom build Windows version of this keyboard that you can find here. I like this keyboard, because I don't have the annoying dead keys bothering me, but when I need them, I can easily use them by holding AltGr.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .