5

I bought a PC without optical drive and there is no option to borrow it for a short time.

So I am using Rufus to create a bootable USB stick.

I have a 16Gb Toshiba USB drive.

Using a Rufus's built-in FreeDOS image I found that "MBR partition scheme for BIOS or UEFI-CSM" is the only option to create bootable USB drive that the motherboard understands and boots from.

Then I created a test USB drive with Ubuntu 12.04 LTS setup and installed it without any issues.

When I try to write Windows Server 2008 image which is of 3GB size, I can write the USB stick either with "MBR partition scheme for UEFI" or "GPT partition scheme for UEFI", but my AsRock motherboard can't boot from this stick.

When I choose "MBR partition scheme for BIOS or UEFI-CSM" Rufus forces me to choose NTFS. When I click on "Start" it writes some structures but then hangs forever on trying to write MBR:

Format operation started
Requesting disk access...
Opened \\.\PHYSICALDRIVE1 for exclusive write access
Requesting lock...
Will use 'E:' as volume mountpoint
I/O boundary checks disabled
Requesting lock...
Analyzing existing boot records...
Drive has a Rufus Master Boot Record
Volume has an unknown Partition Boot Record
Clearing MBR/PBR/GPT structures...
Erasing 128 sectors
Deleting partitions...
Partitioning (MBR)...
Closing existing volume...
Waiting for logical drive to reappear...
Formatting (NTFS)...
Using cluster size: 4096 bytes
Quick format was selected
Creating file system...
Format completed.
Writing master boot record...
Drive has a Zeroed Master Boot Record
Set bootable USB partition as 0x80
Using Rufus MBR
Found volume GUID \\?\Volume{8c687e53-2e9b-11e7-a9e7-c19b1afa280e}\
Waiting for access on \\?\Volume{8c687e53-2e9b-11e7-a9e7-c19b1afa280e} [\Device\HarddiskVolume35]...

Then waits a little bit and reports:

Warning: Could not obtain exclusive rights. Retrying with write sharing enabled...

and then it may wait forever.

User interface is responsive, but the only way to terminate Rufus is to kill it in task manager.

It happens only when I use NTFS with this partition scheme.

What to do?

4 Answers 4

3

you should check for any antivirus software conflicting with rufus.
for example see: https://github.com/pbatard/rufus/wiki/FAQ#Incompatible_Software

in my particular case rufus was hanging (while trying to write the MBR) because of g data antivirus with behavior monitor enabled:

g data

2
  • I have turned antivirus off and it will start creating with no problem. Jul 13, 2019 at 18:59
  • Ah windows start create mess again... ControlledFolder Access turned off then it will work. It happen since 20h2. come on guys... Dec 16, 2020 at 8:26
-1

To ensure that the USB flash drive is UEFI bootable, change Partition scheme and target system type to GPT partition scheme for UEFI.

I had the same problem then I did this and it worked.

-1

Don’t even complicate it by logs n stufff

Here is a simple solution which allows u to create a persistence partition as large as u want! 1 Tb 100 Tb ....n so on Only the limitation is ur physical disk space not a software bug

Note-By viewing the scenario it is clear that there is definitely a problem with the formatting module of rufus.

Now here is a solution

  1. Set the persistence partition to 1GB
  2. Within a few minutes your file will be flashed on the usb .
  3. Supposedly I want to create a 100 gb partition
  4. I have a 128 gb usb
  5. 28 Gb a reserved for my iso boot sector, 1 gb as persistence and 99 gb unallocated memory
  6. Now our goal is to merge the 99 gb to 1 gb persistence to make it 100 gb persistence which we could not have done otherwise on rufus as it would be stuck on 100% formatting

7.So either arrange a vm or casually boot another iso in an Minimum of 4gb stick. Note- don’t boot in the stick you have to operate on.

8.now install gparted (Linux partition manager for gnome btw) sometimes preinstalled just check and open it.

9.now at the top right u select your 128 gb stick.

  1. Right click on the persistence 1gb sector and unmount it

9.then right click again on the same 1 gb persistence sector to resize and give it a size of 100gb by moving the start and ending black arrows

10.now click on the tick icon and apply the changes (located under the word help btw)

11.it will take some time and then show u that u have a boot partition of 28 gb and persistent partition of 100 gb exactly what u wanted !!

Took me 1 hour to add 50 gb.

Note just to confirm if everything went right, just boot up the usb after resizing and make sure that there is no persistence folder by default on the desktop If there is a persistence folder then redo the process

In the above example u did not mess with the initial 28 go of boot file so don’t worry it is safe!

Thanks.

-2

I encountered the same problem and I was almost pulling my hair until I found a post on Reddit in which a Rufus developer said this(and it was exactly my issue for over two days!):

Rufus dev here. The problem is that the Manjaro people put a bit too much faith in ISOHybrid, and seem to have forgotten that, yes, there are some people who want to create an UEFI bootable drive by simply copying the ISO files to a FAT32 file system (which is pretty much what Rufus does for UEFI boot). So they didn't bother including a FAT32 driver into their GRUB EFI bootloader.

Hence the process fails as follows:

The UEFI firmware finds the GRUB bootloader on the FAT32 partition and runs it (since all UEFI firmwares have support for FAT32)

The GRUB bootloader runs and starts to looks for its configuration files on a file system it can handle... but since the Manjaro people have only included a module for ISO9660 file systems in GRUB, and not FAT32, it can't find that file and bails out with a prompt.

Note that we have reported this issue to Manjaro months ago, but they still haven't done anything about it. So if you want to help, please pester them to address that issue, as we have reasons to believe it should be exceedingly easy to fix, and would avoid many more Manjaro users to run into this easily avoidable issue.

And of course, as was correctly suggested, you can always fall back to using "DD mode" when prompted by Rufus to work around that problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.