0

I have a resume formatted in Microsoft Word with job titles (formatted as Heading 2) and job location (Normal Text) listed on a single line.

Header from resume

Unfortunately, having two different Styles on a single line can be a bit finicky, causing unintended side effects.

I've found that sometimes the Heading font style will apply correctly, but they will not show up in the Document Map or Table of Contents unless the Heading style is applied to an entire line with no other text.

Document map

The only helpful reference I've been able to find is an old forum post that was answered by linking to an article which is no longer available.

Is it possible to have a Heading Style on the same line as normal text which has no styles applied?

  • 1
    SInce you're using Word 2007, you'll probably want to use a style separator. – cnread Jul 8 '17 at 19:16
0

Another possible approach is to modify the heading style so that it's inserted in a frame. If Frame appears in the Format drop-down at the bottom of the Modify style dialog box, you can specify that the content of the heading should be in a frame, and that the surrounding content should flow around it. See, for example, this Super User question; although this involves side headings in the left margin and is for a later version of Word, the basic principles are the same.

(When I suggested using style separators in my comment, I didn't think this functionality for applying frames to paragraph styles existed in Word 2007, but this page and others indicate that it did.)

Unlike headings in a table, headings in a frame will show up in both the TOC and the document map (Navigation pane in later versions of Word).

0

You can use style separators as @cnread suggested in the comments. However they require too much effort to apply and manage.

For a small document I would suggest using a table with two cells, one with the Heading text and the other with the normal text. Remove the borders and align both cells to the bottom.

Here's an example (I've kept the borders visible to show the table structure):

enter image description here

  • The issue here is that the heading needs to show up in the document map (navigation pane). Although heading styles that are applied in a table will show up in the TOC, they won't show up in the nav pane. – cnread Jul 8 '17 at 21:03
0

I've seen this "style lock" trying to juggle multiple styles in the same line for some time due to using the third level of the APA Format Style. I used Word versions 2007, 2013 and 2016 and things worked well until the style lock occurred last month. Although it sounds like it should work, the style separator didn't break the lock. But today, I found a work-around.

Today I changed the document to a Macro Enabled document, but no style difference. Next, I double toggled the link styles box check mark at (CTRL+ALT+SHIFT+S) and then used the style boxes at the top of the screen to set the style for a selected word in the heading instead of the styles drop down, box.

It works, as long as I use the style boxes at the top on the highlighted word.

Then I saved it back as a Word Document (2016) and it still works. So, it looks like the toggling affect seemed to bring this function back, but only for the top boxes.

Then, working on a paragraph, another style lock-out occurred. When I try to change it again it won't. So, I CTRL-X (Cut) the heading out, make everything Normal style again, paste it back, and now it works again. And it works with the drop-down box, and for any style, but I still don't understand what toggles this feature off and on. Working it again, the style lock occurs, so I changed everything back to normal, highlight just what I care to change, and then it works and works even on the drop-down box.

I also examined the style and paragraph of the heading and there was a drop down in the modify the style menu- but changing the style in the "style based on:" box didn't break the style lock. Clearing all styles from a paragraph didn't break the lock either.

But it is working now, so thanks to all who posted.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.