0

I'm attempting to re-purpose and old Toshiba Satellite laptop for use as a server. I have created an Ubuntu Server installation USB, and tested it successfully on my personal laptop.

I have booted in BIOS and set USB to the top of the boot order. However, rebooting the system, the boot fails.

This is perhaps because of Secure Boot being enabled in BIOS settings, although I cannot find any option related to secure boot in BIOS, and thus am unable to boot into the USB.

Laptop model is Toshiba Satellite L855D-S5220, BIOS version is latest: 6.20

  • "the boot fails" what appears on screen? I've used Ubuntu with secured boot enabled in the past just fine, dunno if it supported in the server versions though – athosbr99 Jul 9 '17 at 2:39
  • 1
    ALL Windows 8 and Windows 10 devices are required by Microsoft, in order to be sold with Windows 8 an Windows 10, to be able to disable Secure Boot. The only exception to this rule was Windows RT, which your device cannot run, so the exception doesn't apply to your device. So the option must be there, if your laptop, even supports Secure Boot. Windows 7 devices sold didn't support the UEFI revision that supported Secure Boot, your laptop appears to have supported Windows XP which means, you don't even have UEFI. Only Windows 8 and Windows 10 devices supported Secure Boot. – Ramhound Jul 9 '17 at 3:19
  • 1
    Your inability to boot to the installation USB, likely has nothing to do with Secure Boot, and everything to do with how it was created. – Ramhound Jul 9 '17 at 3:19
  • Perhaps, but I have been able to successfully boot from this USB drive on my laptop. I guess I'll call Toshiba support tomorrow. – Hussain Khalil Jul 9 '17 at 4:48
2

The "detailed specs" PDF on the page to which you linked indicates that the computer originally shipped with Windows 7, perhaps in 2012 (one document bears that date as a copyright). As such, it might use BIOS firmware or (U)EFI firmware. I don't see any other clues as to which it might have been. Even if the computer is EFI-based, it likely does not support Secure Boot, which would explain why you can't find such options. (Most manufacturers added Secure Boot support with computers that shipped with Windows 8.) In theory, Ubuntu should boot with or without Secure Boot enabled. In practice, it usually works either way, although there are some very rare situations in which Secure Boot can prevent Ubuntu from booting, and somewhat less rare situations in which Secure Boot causes other problems (like difficulties using third-party drivers).

You've neglected to mention three critical pieces of information:

  • How did you create the USB drive? Most methods of creating a bootable USB drive from an Ubuntu installation .iso image work on some computers but not on others. Switching from one program to another may fix your problem; or you may be able to adjust options within a single program. Personally, I generally use the dd method of copying the .iso file to a USB drive. If you're doing this from Windows, Rufus seems to work better than most -- but Rufus also offers options that you may need to adjust. See this page of mine for more on this subject.
  • How did the boot fail? You say that the attempt to boot the USB drive failed, but you provided no details. Did the computer not recognize that you had a bootable USB drive? Did it start to boot the USB drive but then hang? Did you see an Ubuntu logo at any point? Did the computer spontaneously reboot? Did it show any error messages? Any detail might be helpful in diagnosing the problem.
  • What version of Ubuntu are you using? You did specify Ubuntu server, but not the version number. As a general rule, the more recent the Ubuntu the better. That said, your computer is old enough that it should work with anything that's currently supported, so this may not be important unless you're using something truly ancient and unsupported (like Ubuntu 10.04). OTOH, there might still be a bug or quirk that could require use of a particular version, or to avoid using a particular version.

Given the information you've provided, my only solid advice is to try another tool for creating a USB flash drive. If that doesn't help, please clarify the above questions. Also, please check the firmware setup screens for any mention of "EFI" or "UEFI" options, or for "legacy boot" support. If such options are present, your computer is likely EFI-based, and so can probably be booted in either BIOS/CSM/legacy mode or in EFI/UEFI mode. One method might work better than the other. If you can't find such options, the computer might be a BIOS-only system, in which case solutions based on EFI-mode booting will likely be useless to you.

-1

In the BIOS, look for the Secure Boot setting, and if possible, set it to Disabled. This option is usually in either the Security tab, the Boot tab, or the Authentication tab.

Look for a setting called "Boot Mode", "UEFI Boot", "Launch CSM" or whatever else it may be called, change the boot mode from UEFI to Legacy/CSM: disable the UEFI Boot option and enable CSM Boot support.

Note that the Compatibility Support Module (CSM) may not be present on all UEFI PCs. On some UEFI PCs, it supports UEFI only, without an option to enable CSM/Legacy support.

(summary of this: https://www.top-password.com/knowledge/disable-UEFI-enable-legacy-support.html)

  • 1
    As a general rule, I disagree with blanket advice to disable Secure Boot or to boot in BIOS/CSM/legacy mode. In this specific case, this advice is unlikely to hurt, since it's being set up for a single-boot configuration, but it may not help. It's better to figure out what's going on before adjusting these settings without specific goals in mind. – Rod Smith Jul 11 '17 at 13:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.