3

Overview

Over the course of a few months I purchased two of the same SSD from different stores (both 960GB SandDisk SSD PLUS, same firmware(Z33110RL) - just waited for them to be on sale) with the intention of combining them in RAID0.

When the second drive arrived, I benchmarked both to make sure everything was working.

enter image description here

For convenience, I used a drivebay (like in the image above) on a SATA port configured for hot swapping in the BIOS to test the two drives using CrystalDiskMark. I used the same sata port, simply swapping one for the other.

enter image description here

I noticed that one of the drives (the one I had just purchased, and so had not used yet) was performing drastically worse than the other, despite being on the same motherboard(GA-Z97M-D3H), on the same SATA connection, and the same model(960GB SandDisk SSD PLUS) with the same firmware(Z33110RL).


Different Transfer Mode

I tried forcing Trim, reformatting again, copying some files to it, etc. but the results were consistent, and I tried swapping the drives back and forth several times; The results never changed, and the new drive was consistently about 1/4 of the speed of the other one on Sequential tests.

Checking CrystalDiskInfo to see if there were any discrepencies, I noticed that the slow drive was showing its Transfer Mode as SATA/150 | SATA/600, meaning that it was using SATA/150 but supported SATA/600, while the other drive was showing SATA/600 | SATA/600.

The slow drive:

enter image description here

The fast drive:

enter image description here

Swapping the two drives will consistently yield this behaviour, the newer one (serial number ending in 193) is always using SATA/150, while the other one (serial number ending in 876) is always using SATA/600.


Question

What would cause this behavior? What determines the selected 'Transfer Mode' for the drive?

The drives are -identical-, both formatted to NTFS, and are being tested on the exact same motherboard/port/etc.

I have used this hot-swap bay with dozens of drives before, and none have ever acted up like this.

0

Yep, had a similar problem, the answer turned out to be that the manufacturer had mislabeled the drive. It was a "Crucial" disk and they replaced it, after I convinced them that this was the problem. You might check that!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.