Let's say I have a PC with two monitors atached. I'm running e.g. Windows Vista natively, and start up a virtual Ubuntu PC. I change to fullscreen mode so that on one Monitor, I see my Windows Desktop, and on the other one, the Ubuntu Desktop. I can now use my mouse and Keybord for both of them.

This works fine, but I'd really like to connect a second mouse and a second keyboard to my physical PC, and do some configuration so that one set of input devices is used for Windows, and another set for the virtual Ubuntu. Then two persons could work at the same time, as if they were using two separate computers, although there is only one physical machine.

I'm currently using Sun VirtualBox and it has a feature to assign specific USB devices to the virtual machine. While this sometimes works for e.g. external disk drives, it never worked for mice and keyboards for me (yes, of course my input devices are attached via USB!).

I'd like to know a solution that works with VirtualBox, but any answer is appreciated, even if another virtualization software or some additional hardware was needed.


3 Answers 3


The wikipedia article on Multiseat desktop virtualization lists several solutions.

The more general concept is Multiseat configuration, which is not specific to virtual machines, but if required, one of the users could run a virtual machine program at their seat.

A multiseat, multi-station or multiterminal configuration is a single computer which supports multiple independent users at the same time. In modern usage the terms refer to multiple users using one personal computer, each with their own console, consisting of a keyboard a mouse, a monitor, and possibly headphones.

  • Good point - the audio also has to be separated. Aug 5, 2013 at 22:01

You can do this with virtualbox. I tested it with version 3.0.2 (not the OSE) with ubuntu as the host and XP as the guest, but this shouldn't make a difference. First you have to change the settings of the machine to pass the USB devices to the VM, but I guess you have already done that. For the keyboard you should disable "auto capture keyboard" under File->Preferences->Input. Then you start the VM and disable mouse pointer integration. Good luck!

  • Thanks for your answer. I just upgraded to 3.0.2 and still it does not work. But it actually appears to me that USB integration is not working at all on my Vista host, and neither on my XP host. I'm gonna try this on a OS X host soon and report if it's working there. If it works there, I'll consider filing a bug at virtualbox. Jul 29, 2009 at 9:21
  • Did you add the devices under Settings->USB? Did you make all the settings I suggested? I'm not sure, but maybe you need the guest additions for this to work. What I'm 100% sure about is that if this was a bug, it would be fixed by now. It should even work with version 2.x but I don't have that installed here.
    – Kim
    Jul 29, 2009 at 15:18
  • Yes, I made all those settings. I also had the chance to test this on a OS X host, and the menu entries to assign the USB mice and keyboards were grayed out, while those for other USB devices were available. So it wasn't workint there neither. I'm going to update my question with some screen shots soon - right now I don't have access to the host machines. Aug 3, 2009 at 9:22
  • Experiences with vmware?
    – Edoardo
    Oct 18, 2018 at 8:57

I am using Windows 7 Pro x64. My VM is Kali Linux, the virtualbox I have is 4.2.xxx. I only installed extension pack and mounted the USB mouse and keyboard to the VM and it worked. I think it would have worked even without extension pack

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .