2

I have a fresh Windows 10 64-bit install, which I'm attempting to set up for development.

I have

  • downloaded and installed cmder, then rebooted
  • downloaded and installed Vagrant, then rebooted
  • downloaded and installed VirtualBox, then rebooted
  • set VAGRANT_HOME=c:\vagrant
  • used VBoxManage setproperty machinefolder c:\virtualbox-machines
  • acquired my department's VagrantFile, and modified it to suit my filesystem.

In cmder, if I now run

vagrant box add http://opscode-vm-bento.s3.amazonaws.com/vagrant/virtualbox/opscode_centos-7.0_chef-provisionerless.box --name chef/centos-7.0

I get no output. No failure codes, no windows errors, no logs from vagrant. The same is true of all vagrant commands, up to and including vagrant --version and vagrant --help. Other commands work fine in cmder.

However, if I run a basic command line, cmd.exe, then the vagrant box add command completes correctly. An, as far as I know, identical setup worked under Windows 7 32-bit.

Can anyone suggest what might be going wrong?

13
  • 1. ConEmu version. 2. Screenshots after executing vagrant commands.
    – Maximus
    Commented Jul 10, 2017 at 23:34
  • 1
    @Maximus - ConEmu looks like ConEmu 161022 [32] (which is a little odd, because it's a Windows 10 64-bit install - but that's what came with cmder). There's no point getting screenshots - there is literally nothing after running a vagrant command. Just one blank line, then the next prompt.
    – Chowlett
    Commented Jul 11, 2017 at 8:00
  • Update ConEmu to latest alpha
    – Maximus
    Commented Jul 11, 2017 at 12:18
  • 1
    @Maximus - now running 170709 [64]; no change. Still no output from (for instance) vagrant --version.
    – Chowlett
    Commented Jul 11, 2017 at 12:37
  • A coworker on windows had this problem this morning, he was using latest stable and latest version of cmder both facing this issue. I asked him to use conemu directly instead, he installed conemu using chocolatey and now his vagrant command works.
    – GabLeRoux
    Commented Jul 11, 2017 at 12:58

2 Answers 2

3

There is something wrong with the git-for-windows that is vendored with cmder and vagrant. However, cmder allows you to have your own install of git-for-windows.

To fix this issue with vagrant working and cmder:

  1. Install git for windows from https://git-scm.com/
  2. Ensure your PATH includes the path to the git you just installed (default should be: C:\Program Files\Git\cmd)
  3. Restart cmder

Cmder should then detect the custom git install and use that and there will no longer be a problem with vagrant.

Editing the cmder vender\init.bat is not a great solution because this can be replaced by cmder in a future update.

0

Hey I just talked with the guy who had the problem here at the office, he said the problem was related to its $PATH not being set correctly for git.exe.

Problem is with the way C:\Tools\cmder\vendor\init.bat loads git. (I still don't know why git have anything to do with preventing vagrant from running).

  1. Make sure C:\Tools\cmder\bin; comes first in the list
  2. Remove cmder's git-for-windows (he also renamed it to a different path just to make sure it doesn't get used by cmder).
  3. Use official git binaries and add C:\Program Files\Git\usr\bin; to to your PATH.

After doing this, he was able to run vagrant commands from cmder like before. Hope it helps. Good luck!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .