9

How do I get rid of the sidebar thing below?:

enter image description here

12

The thing is called Minimap.


Recommended: To change it from within VS Code...

  • on all systems, the easiest way is to use the menu: View -> Toggle Minimap (as shown on the screenshot below).

Screenshot of VSCode menu

  • on all systems, you can also press Shift+Ctrl+P (on Mac, Ctrl is replaced by ) and search for Toggle Minimap within the Command Palette.

As with all settings in VS Code, you can also change it via settings.json.

  • on Windows / Linux, you can press Ctrl+, (it's a comma). (This could also work on OSX, but I have not found a reference and I cannot test it myself).
  • on all systems, you can press Shift+Ctrl+P (on Mac, Ctrl is replaced by ) and then search for Preferences: Open user settings.

Now, you should see a new file-tab called User settings and in it a two-pane viewer with its own search bar.

There, you look for editor.minimap.enabled and change its value to false. (You can also just add "editor.minimap.enabled": false to your settings.json and save it.)

If you want to change it for your current project only, you can select Workspace Settings to the right of the setting window's search bar.

That's it!


If you want to edit it from outside VS Code for some reason, open in...

  • Windows: %APPDATA%\Code\User\settings.json.
  • OSX: $HOME/Library/Application Support/Code/User/settings.json.
  • Linux: $HOME/.config/Code/User/settings.json.

Then, just add "editor.minimap.enabled": false to your settings.json and save it.

If you want to change it for your current project only, you can also look in your project's .vscode-folder - there, another settings.json can be found.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.