0

my goal is to print a generated testreport (pdf, 1 A4 page) to any network postscript printer ( The printer is not fix, it only has to be a postscript printer. I tried Brother HL-5450DN & Brother HL-5370DW ).

Problem:

I tried CUPS with raw queues, but the Brother HL-5370DW (postscript capable) only print blanks.

Question:

  1. Is it possible to print the pdf driverless, more closer without ppd files ?
  2. Can i use ipp/ipptool for this problem.

Environment: embedded linux image (3.14) with build-in cups,

Best regards Lars

  • PDF does contain postscript commands, but it is not postscript. So convert the PDF to postscript, and try to print that with raw queues on postscript printers? – dirkt Jul 11 '17 at 8:31
  • i tried to convert with ghostscript ( GPL Ghostscript 9.15 ) : gs -dNOPAUSE -dBATCH -sDEVICE=ps2write -sOutputFile=report.ps report.pdf but it prints only a blank on both printers. – larsdd Jul 11 '17 at 9:08
  • Wrong postscript level? What postscript levels do the printer support? Do you have an example file that prints correctly? – dirkt Jul 11 '17 at 9:42
  • yes i think so, more closer wrong postscript "mime-type". both printers support level 3. I tried a fileprinter of my vm ( cairo 1.14.2). this generate a ps that both can print. – larsdd Jul 11 '17 at 9:55
  • is it possible to run this conversion via a cups filter/backend solution without a ppd file. – larsdd Jul 11 '17 at 10:03
0

BrScript3 has some bugs, I think. In some cases, gs -sDEVICE=pswrite works better than -sDEVICE=ps2write for Brother PS printers, I don't know why.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.