1

I have a bootable USB drive with Kali Linux on it

When I try to boot off it, my BIOS will alert me that it cannot boot due to a *SECURITY VIOLATION*

Then it boots to my current OS. (Ubuntu) How do I stop this from happening and boot to Kali?

Thanks in advance!

  • 3
    If you're going to run Kali you should be able to get around a simple BIOS security feature, right? ;) Did you check if secure boot is disabled? – mtak Jul 12 '17 at 7:14
  • 2
    @mtak Just look at all the questions with the "Kali-linux" tag :) – xenoid Jul 12 '17 at 10:48
  • 1
    Oh forgot about the BIOS feature. – Enzo Gladiadis Jul 12 '17 at 21:26
6

Your BIOS has secure boot configured. This is a newer feature introduced with EFI that allows installed operating systems to "register" themselves with the bios. The bios will then only allow those OSes to be launched. It also, by default, refuses to boot from external/removable media.

You should find the secure boot options in your bios settings near where you configure boot order. Simply turn secure boot off. Do not turn EFI off as you may need EFI to boot Ubuntu (if it was installed with EFI turned on, the Ubuntu installer defaults to EFI mode for the bootloader).

| improve this answer | |
2

Disable secure boot in your BIOS.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.