63

I got a pair of Plantronics bluetooth headphones. Work great with my iPhone. Sounds terrible with my Mac, cuts out, sounds choppy, sounds mono to me. A co-worker tells me he has the same problem.

BTW, I'm on Leopard, patched up.

So question is: What is the deal? Is it fixable?

migrated from stackoverflow.com Jul 24 '09 at 15:33

This question came from our site for professional and enthusiast programmers.

  • What is the model? Does it support A2DP? What software are you testing with? Do you have friends that have Macs you can duplicate this on? – Michael Glenn Jul 24 '09 at 16:51
  • If you care about sound quality, go wired – InterLinked Feb 25 '17 at 21:33
  • Try updating your audio codecs by running: sudo defaults write bluetoothaudiod "Enable AptX codec" -bool true and sudo defaults write bluetoothaudiod "Enable AAC codec" -bool true – marcelosalloum Apr 13 at 20:26
236

In case anyone ends up here, like me, experiencing this problem on a more recent Mac OS (in my case Sierra): None of the other solutions here worked for me. Sierra doesn't give the option to connect in headset or headphones mode, and the bitpool setting made no difference.

I finally figured it out: Going to sound preferences and manually changing the sound input device back to Internal Microphone seemed to switch my headset into headphone mode, making the sound quality worlds better.

Note that you can also do this faster by option-clicking on the volume icon in the menu bar.

Hope that helps someone out there.

  • 17
    This should be higher up. Apparently this is the only way to turn off A2DP in Sierra. – Adam Shiemke Jan 5 '17 at 21:51
  • 2
    I realised the same thing. It's worth pointing out that this appears to do what it says, and uses the computer's internal microphone – meaning that the microphone may catch more background sounds that you would like. – Henrik N Jan 10 '17 at 15:04
  • 17
    This solution worked but every time I turned off and reconnected my headphones the sound input got set back to the headphones. After playing around in the Audio MIDI Setup tool I found a way to fix this by creating an "Aggregate Device" using the plus button in the bottom left. Select only the built in microphone for your new aggregate device and then set the aggregate device as your sound input. The aggregate device will remain selected as the sound input device when connecting your headphones, even after rebooting. – CrimsonChris Sep 23 '17 at 3:43
  • 2
    Those without a built-in mic may benefit by installing Loopback or similar in order to create a virtual audio device. – Chris Jul 23 '18 at 21:23
  • 5
    This should be the selected answer. Still a problem in August 2018. – Greg Hilston Aug 10 '18 at 18:46
4

Make sure that when you pair the headset you select "use as wireless headphones" (or similar) instead of "use as headset". The headset profile was designed for phone calls, and you should only use it if you're pairing a headset that does not support A2DP.

Your Plantronics headset probably supports both (if it has a microphone) because some devices switch between the two profiles for music-listening and call-taking.

  • 2
    I don't see any affordances to choosing "headphones" vs "headset" in macOS. – Merchako Dec 12 '18 at 0:30
3

I have a Motorola A2DP headset and on occasion with it pairs in headset mode with my MacBookPro it's very staticy and the sound is sub-par. Usually, by disabling bluetooth and then turning it back on and resyncing everything it works fine again.

It's pretty rare that it ends up with bad sound, but I get the feeling that Apple has pretty crappy bluetooth drivers.

3

Try the method explained by Casey Liss in this post at Casey's Tumblelog.  It tweaks the bitpool setting which makes all the difference in the world.

UPDATE:

The above blog post points to an article on Scott Dier's blog that no longer exists.  However, it can be found on The Wayback Machine here, and it says:

OSX, Snow Leopard, a2dp

So you'd figure with Snow Leopard that sound quality with some a2dp headsets would be better — turns out it isn't.  I was able to 'fix' my sound quality with a Motorola S9 by going to Bluetooth Explorer (option-click on bluetooth to find it) and going into Utilities->Special Options.  I changed the bitpool minimum to 40 and the sound quality is MUCH better.  Sounds like its a problem with negotiation between this headset and OS X.  If you set the value too high OS X will let you know that the headset rejected the codec settings.  I'd figure that 40 is ok for me, but might not be ok for others — use this at your own risk.

Posted by Scott Dier at 11:39 AM (Wednesday, October 7, 2009)

  • Followed these instructions and got noticeably better sound quality. Thanks! – Hassan Nov 9 '11 at 13:29
  • Dead link sadly :( – Tiago Oct 10 '18 at 15:17
  • 1
    Here's a recent post that should help: areilly.com/2017/07/29/… – dzajic Oct 12 '18 at 14:40
1

Ok You are on Leopard which supports A2DP, as opposed to non-stereo on Tiger so that should not be the problem.

Some headphones have a headset mode and get connected in that mode incorrectly and sound awful, so you should endure that your headphones are not being connected in headset mode.

You should also try your headphones with another computer to ensure that you bluetooth adapter is not faulty.

  • The headphones work fine with the iPhone, and most Macs have built-in Bluetooth, so testing with another system shouldn't be a problem. – Andrew Scagnelli Jul 29 '09 at 17:31
0

While I tried a lot of these options that everyone is presenting as solutions, I ended up fixing my headphones a different way. I went to system preferences on Mac and then went to Bluetooth. From there I right clicked on the device (Beats Solo3 Wireless) that was having issues and clicked "remove". After I did that, I reconnected them and now they work fine. My initial problem with the headphones wasn't on an individual platform rather a problem on all platforms within my mac, which includes Spotify, Youtube, FaceTime and anything else you can think of. This will give you another option to try and I hope it helps.

0

I was having the same issue with a pair of Coby E7 bluetooth headphones where they sounded muffled. I went to system preferences and realized that while the audio was playing through the headphones they weren't listed under Audio -> Output as the output source.

I decided to try and disconnect the headphones by going to System Preferences -> Bluetooth and clicked the "X" button to remove them. I rebooted the headphones and repaired them and the issue is resolved and now the headphones are listed as the output source under sound.

Hope this helps.

0

If you have SoundFlower installed, try uninstalling it.  That solved this for me.

Use the SoundFlower uninstaller script located in the original SoundFlower install .dmg file.

0

The top answer by linesarefuzzy worked partly for me.  In addition to switching to internal microphone, I also had to disable dictating (otherwise it had no effect).

To disable dictating, go to: System preferences -> Keyboard -> Dictating, and switch dictating to off.