10

Disclaimer: this is the exact same question as this one but on Windows 10.

I use two different keyboard layouts on Windows 10 (French AZERTY and US QWERTY, not that it matters), both in the English language. I can switch easily with the Windows + Space shortcut which lets you choose between the two.

However, the keyboard layout keeps changing automatically from one to another (at least from French, which I use 95% of the time, to US) and I cannot figure out why. I am absolutely certain that I do not press Windows + Space by mistake, and I am also sure that I don't press Alt + Shift by mistake (which was a key combination that used to allow changing keyboard layout, but apparently doesn't anymore – at least not on this computer).

I have an autohotkey script running in the background but I did not find any hotkey that seems to be able to trigger a keyboard layout change.

Does anyone know how to avoid involuntary layout changes?

9

Below is the answer for anyone interested. It is in two parts for now, I'll edit it when I have time.

  1. One of the questions in the related questions put me on the right track, though I have not solved the issue yet.

On my computer (and apparently and Windows 8 and above), the Ctrl + Shift (not Alt + Shift) key combination is used to switch keyboard layouts. I disabled the Alt + Shift combination (that was theoretically active, but did not work) by going to Control Panel\Clock, Language and Region\Language\Advanced settings\Change Language Bar hotkeys ; but the Ctrl + Shift combination still switches keyboard layout, although it does not appear anywhere, and I cannot figure out why.

enter image description here


  1. FINAL WORD: There are actually TWO hotkeys, one which changes input languages (which is, by default, Alt+Shift) and one which switches keyboard layouts (by default, Ctrl+Shift).

The definitive steps to see those settings are :

  1. Go to Control Panel\Clock, Language and Region\Language\Advanced settings\Change Language Bar hotkeys
  2. In the "Advanced Key Settings" tab, select "Between input languages" and click on "Change Key Sequence..."

You can now choose to enable, disable or change the two shortcuts I mentioned earlier.

enter image description here

  • 2
    Strangely, there is no "Language" option in my Settings / Control Panel. So I had to get there with: Settings > Time & Language > Region & language > Advanced keyboard settings (in Related settings on right side) > Language bar options > Advanced Key Settings – Wyck Jul 11 '18 at 1:36
  • @Wyck The classic panel for this has been removed in recent Windows 10 builds. – Ray Nov 24 '18 at 18:16
  • Thank you very much! I am puzzled as to how I never bumped into this before, having used multiple layouts via Win+Space for years and selecting word-at-a-time via Ctrl+Shift. Also puzzling is why there are multiple settings for the same effect... – ravemir Feb 1 at 11:48
  • 1
    For Windows 10 version 1903: Settings (Win+I) → Devices → Typing → Advanced keyboard settings → Input language hot keys Select any actions with key sequences assigned → [Change Key Sequence...] Select "Not Assigned" as necessary. – maxathousand Jul 23 at 18:15
  • It is also found under Settings > Time and Language > Language > "Use input method to use as default" > "Input language hot keys". Weirdly Settings > Search > hot keys does not work. – Strategy Thinker Sep 14 at 22:42
0

With windows 10, there's also a problem that raises when using more than one computer (like your laptop and desktop) and win 10 syncs settings, hence the last used layout of one computer will be transfered to the other computer.

-1

wasn't enough for me, I still had the problem. For those who still have the problem, I found here in the second page of answers, the one from Khalil Al Hooti on february 16th 2018 that I copy below : "The reason is that your system local is set to English (United Kingdom). so whenever, you start typing in some program with non-Unicode characters, windows will use the default system local language to interpret these characters even if the language is not available in language bar. if you want never to allow this to happen again do the following 1. go to control panel 2. click on clock, language and region 3. click on language 4. click on advanced setting 5.click on Apply language setting to the welcome screen, system accounts, and new user accounts 6. click on change system locale 7. choose to English (United States) from English (United Kingdom) and click OK 8. restart your PC. to remove previously automatically added English (United Kingdom) language keyboard. first add the language from language preference, and the keyboard from the options. remove them again manually. The problem will be solved"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.