0

I have a issue where I can't reach a server that is on a different network than the primary gateway. My network looks like this:

Router 1 (192.168.1.1) ---> Router 2 (192.168.1.129) ---> Server (172.16.1.30).

Router 1 (ASUS RT68U) is the first gateway in the network. Router 2 (ZYXEL USG 100) has a DHCP server with the network IP 172.16.1.1, which assigns the IP 172.16.1.30 to my server. Router 1 has DHCP and NAT enabled. Router 2 doesnt have NAT activated.

How can I access/create a route to the server on 172.16.1.30 from any computer that is only connected to the first gateway at 192.168.1.1?

  • How could your server even access the Internet when router 1 has no idea on how to reach it? – Daniel B Jul 12 '17 at 19:04
  • At which point did I state that I had Internet connection from the server? – MrD Jul 12 '17 at 19:42
0

You have to create a static route on router 1 which will forward traffic destined for 172.16.1.0/24 to 192.168.1.129. How this is done depends on the specific router.

There is a guide for the specific Asus router here. In short:

  • Log on
  • Go to LAN
  • Click on the Route tab
  • Enter as network 172.16.1.0
  • Enter as netmask 255.255.255.0
  • Enter as gateway 192.168.1.129
  • Enter as metric 2
  • Enter as interface LAN or LAN & Wireless

Make sure the server has it's default route (gateway) set to router 2.

  • I did that. It did not work. I added 172.16.1.1 as destination and 192.168.1.129 (Router 2) as the gateway. When I ping the address to the server i get a request timeout as a reply. – MrD Jul 12 '17 at 19:40
  • I tested a static route like the following (didnt work): Destination: 172.16.1.1 (Network ID on Router 2). Server is on this network. Net Mask: 255.255.255.0 Gateway: 192.168.1.129 (WAN IP on Router 2) Would a reboot of the Router 1 help? Could it be some policy or firewall rule causing this to fail? The thing is thought, I haven't added or modified any rules or policies on the Router 2. – MrD Jul 12 '17 at 19:46
  • Firewalls can mess up everything. It's best to disable them while testing (and reenable them afterwards). Can you see if traffic arrives at 192.168.1.129? – mtak Jul 13 '17 at 6:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.