0

We have a weird situation, on one PC using Outlook it sends e-mail using ISP DNS to resolve the server mail. We have set Google DNS in network card settings for IPv4 and /ipconfig all shows correctly the PC is using that.

The e-mail headers however shows that the PC used ISP DNS to resolve the server name, this means that the e-mail will be delivered to spam folder instad. On another PC which is correctly using Google DNS the e-mail have no problems.

Full Headers, this message is being deliverd to SPAM folder

Delivered-To: ***@gmail.com Received: by 10.36.78.131 with SMTP id r125csp643551ita; Fri, 14 Jul 2017 02:07:59 -0700 (PDT) X-Received: by 10.36.253.139 with SMTP id m133mr2761477ith.42.1500023279035; Fri, 14 Jul 2017 02:07:59 -0700 (PDT) Authentication-Results: mx.google.com; spf=neutral (google.com: 79.7.146.129 is neither permitted nor denied by best guess record for domain of postmaster@ufficio) smtp.mailfrom=Ufficio Received-SPF: neutral (google.com: 79.7.146.129 is neither permitted nor denied by best guess record for domain of postmaster@ufficio) client-ip=79.7.146.129; Received: by 10.36.104.211 with POP3 id v202mf6588322itb.1; Fri, 14 Jul 2017 02:07:58 -0700 (PDT) X-Gmail-Fetch-Info: info@***.it 24 ***.it 110 info@***.it Received: (qmail 876782 invoked from network); 14 Jul 2017 11:06:58 +0200 Received: from host129-146-static.7-79-b.business.telecomitalia.it (HELO Ufficio) (79.7.146.129) by ***.***.biz with ESMTPA; 14 Jul 2017 11:06:58 +0200 From: *** *** <info@***.com> To: "'###'" <info@***.it> Subject: 14 lug Date: Fri, 14 Jul 2017 11:06:52 +0200 Message-ID: <000c01d2fc80$89278e10$9b76aa30$@com> MIME-Version: 1.0 Content-Type: multipart/alternative; boundary="----=_NextPart_000_000D_01D2FC91.4CB05E10" X-Mailer: Microsoft Office Outlook 12.0 Thread-Index: AdL8gIiaOXjXbln+SrqdHyqR4Z4a7w== Content-Language: it X-PPP-Message-ID: <20170714090658.876780.46970@***.***.biz> X-PPP-Vhost: ***.com

6
  • Which header, exactly, do you think shows which DNS server was used?
    – Daniel B
    Jul 14 '17 at 9:40
  • @DanielB Received: from host129-146-static.7-79-b.business.telecomitalia.it Jul 14 '17 at 9:42
  • I don’t see how the IP address behind that host would ever resolve to something else. What do you expect to see there?
    – Daniel B
    Jul 14 '17 at 12:33
  • @DanielB I'm trying to e-mail using my domain address, since outlook is using ISP DNS it fails to resolve it, hence my ISP is using its own SMTP to deliver the e-mail. This result in a message marked as spam. Jul 14 '17 at 13:09
  • I’m not sure that chain of events is solid. Your ISP’s SMTP can’t just hijack the mail delivery. Outlook doesn’t do anything like that either, it uses the configured SMTP server to send the mail or fails.
    – Daniel B
    Jul 14 '17 at 13:15
1

Outlook will use the DNS servers set for the system; it doesn't somehow figure out what your ISP uses for the IP addresses of their DNS servers and then use those for DNS queries. Unless your ISP somehow redirects DNS queries sent to other DNS servers to its own, a highly unlikely event, Outlook will use the results returned from DNS servers set at the system level.

You mentioned in a comment "but the message ends in spam folder, Google thinks it is relay or something, hosting company said Outlook is using ISP DNS and not my system DNS (google) therefore it ends in spam folder." Unless you misunderstood what the hosting company said, the statement that Outlook is using the ISP's DNS, so that is why a "received from" header has the value below makes no sense, since Outlook isn't adding that line when it sends the email. That line is added by a receiving SMTP server.

Received: from host129-146-static.7-79-b.business.telecomitalia.it 
(HELO Ufficio) (79.7.146.129) by ***.***.biz with ESMTPA; 

The issue isn't that Outlook is using the ISP's DNS servers. Instead, it is likely that when you send using Outlook that your external IP address, e.g., the one assigned to the external interface on your router, appears as the originating IP address for the email in the message header. If that IP address is on a blacklist, e.g. a DNS-based Blackhole list (DNSBL), used by Google, it is likely to be deemed spam. E.g., when I ran a blacklists check of the IP address at MxTools, I found the IP address in the Received: from host129-146-static.7-79-b.business.telecomitalia.it header field was on a Spamhaus blacklist, though no other blacklists were found to list that IP address. When I checked the details at the Spamhaus site, I saw the following:

It is the policy of ASN3269 / ASN-IBSNAZ TELECOM ITALIA that unauthenticated email sent from this IP address should be sent out only via the designated outbound mail server allocated to ASN3269 / ASN-IBSNAZ TELECOM ITALIA customers. To find the hostname of the correct mail server to use, customers should consult the original signup documentation or contact ASN3269 / ASN-IBSNAZ TELECOM ITALIA Technical Support.

So, you could either whitelist the sending email address through the settings of the recipient Gmail account or you can change the Outlook settings to use your ISP's designated SMTP server.

If you are sending an email by composing the message in Gmail's web interface, instead of sending it through Outlook, the message is going out through one of Google's designated SMTP servers, so, of course, Gmail won't block that email.

1

This is not Outlook. Your ISP's SMTP server appends the "Received" header with the IP or DNS address of the incoming connection that is your router's IP assigned by ISP it its turn.

This is how SMTP email delivery works.

7
  • That’s certainly true. However, it’s not the whole truth. The header does indeed contain the previous hop host name as reported by HELO.
    – Daniel B
    Jul 14 '17 at 12:32
  • 1
    @DanielB, HELO/EHLO is extremely unreliable source in this case. Most of modern SMTP servers use the actual incoming IP.
    – thims
    Jul 14 '17 at 12:57
  • @thims, for some reason outlook is using ISP DNS to resolve my host name, my ISP fail resolving the domain name and uses its own SMTP. In Outlook I have set my own domain name pop/smtp and supposedly it should be resolved using network DNS not my default router DNS. Jul 14 '17 at 13:11
  • 1
    No, you misunderstand. The complete format as used by Exchange and Google is Received: from HELO_name (DNS_name [IP_address]). Other servers are probably similar.
    – Daniel B
    Jul 14 '17 at 13:11
  • 1
    @Ritardi.Net, your "Received" headers are good and correct. One more time: your ISP's SMTP adds the first "Received". You can't actually do anything here to change this behaviour other than contacting ISP =)
    – thims
    Jul 14 '17 at 13:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.