Occasionally, a forced restart is happening on my Windows 10 computer. When the OS is restarted every program that I've had prior to the restart is reopened at startup. The programs are reopened like I would just double-click them.

I usually hold 5-6 windows of Visual Studio and few more programs all together. When the above happens, I have to wait several minutes until I can start working, as everything takes ages to load.

Is there a setting to disable these programs from automatically opening at startup?

  • 4
    This is a new thing, and it is happening to me. I am not on a domain and do not have the Creators Update. What is surprising is that there is little information about it online. You can read about it a bit here: windowsreport.com/restore-apps-pc-reboot What's strange is that I cannot find the settings to turn it on or off as that article describes. – jdgregson Aug 9 '17 at 19:22
  • 13
    I'd love a way to disable this new behavior. When my pc restarts I want a nice clean slate and not 20 programs trying to open – mejobloggs Aug 10 '17 at 9:46
  • 5
    How is this not regarded as a major security flaw? If I turn off my PC with, for example, a YouTube video open then somebody else can turn it back on and listen to what I was watching without knowing my account password because the video starts playing as soon as windows boots. – Ubiquitous Feb 10 at 9:07
  • 4
    Another stupid decision by Microsoft. It defeats a large part of the purpose of restarting a Widows machine - to close running apps, stop rogue processes, and generally return to a known good state. – DaveBoltman Mar 13 at 6:42
  • 2
    @johni have you had an opportunity to try any of the proposed solutions? I'm sure that your schedule is very busy, but this question now has more than 95k views and it would really be nice if the original author provided us with some feedback. Thanks for your help! – Run5k Jun 3 at 15:53

Good news! It has been somewhat "fixed."

I was interested in clickbangdead's solution, but unfortunately I could not make it work no matter what I tried. Then I went back to the Microsoft Answers thread where he originally posted his solution, because maybe someone could have found a new solution in the subsequent pages. And voilà, indeed. Navigate to the following location:

Settings > Accounts > Sign-In Options

Scroll down to Privacy on the right and then set the following to Off:

Use my sign-in info to automatically finish setting up my device after an update or restart.

Privacy Settings

I was skeptical, because that doesn't seem like it has much to do with reopening my Google Chrome upon restart, but I tested and it (finally) works!


Update: with the release of Windows 10 version 1803 (the April 2018 Update), Microsoft modified the wording within that Privacy option to emphasize that it will "reopen my apps" if it is configured to be On.

Use my sign-in info to automatically finish setting up my device and reopen my apps after an update or restart.  

Disable Reopen My Apps

  • 5
    This works well on version 1709, build 16299.248. – F. Gran Feb 21 at 23:21
  • 2
    Great find thanks. This should be the accepted answer. – Aidan Mar 3 at 11:33
  • 2
    But what are the side effects? – Ray Mar 14 at 19:33
  • 2
    Doesn't work in Version 1709 Build 16299.192. – Reeshabh Ranjan Apr 7 at 4:14
  • 2
    yeah this seems to have stopped working on the most recent version – Bananenaffe May 8 at 19:18

From: Stop Auto Reopen of Programs after Restart in Windows 10

This is a new "feature" in Fall Creators Update. To prevent apps from being reopened after reboot, don't use the Start > Shutdown button. Instead, use the shutdown.exe command-line.

shutdown.exe /s /t 0

To restart, use this command-line or shortcut:

shutdown.exe /r /t 0
  • 43
    As someone that likes the convenience of Start > Shutdown, I'd prefer a solution that doesn't require me to make a shortcut or manually run shutdown. – Johannes Nov 3 '17 at 4:38
  • I added it to the Start menu like so: Put the shutdown command above in a file named shutdown-now.cmd (or whatever you want), created a shortcut to it, and moved it to the shell:programs folder (more on shell commands). Next I right-clicked it in the Start menu and chose Pin to Start. For bonus points, right-click on the shortcut in Explorer, choose Properties, Change Icon..., and pick something you like. – User5910 Jan 29 at 4:19
  • 2
    As of February 2018, there is a 'fix' that doesn't require you to workaround your default shutdown behavior. It i's explained in the answers down below, it is a simple setting switch to turn off. – Vinícius M Mar 4 at 13:37
  • What about when your PC auto restarts over night though? My issue is coming back to work in the morning, finding my pc has restarted, then trying to deal with it opening 30 programs that each pop up error screens because they can't connect to server, or load projects etc. – mejobloggs May 9 at 20:27

Sadly this (privacy settings/use my sign-in info...) doesn't work (at least for me on four machines). It seems like this always happens when you reboot:

https://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_desktop/programs-autostart-after-boot-in-windows-10/09dd8d3e-7b36-45d1-9181-6587dd5d53ab?page=2

quote from a MS Support Engineer over there:

Old behavior:

  • When you shut down your PC, all apps are closed

  • After reboot/restart, you have to re-open any app you'd like to use

New behavior:

  • When shutting down your PC, any open apps are "bookmarked" (for lack of a better word)
  • After reboot/restart, these apps will re-open automatically

If you want to start with no apps open (other than those set to auto-start via Task Manager/Start), you'll need to ensure all apps are closed before shutting down or restarting the PC.

Wish they had included this for "installation/updates require a restart" only. Didn't find any GPOs so far or any way to turn it off.

  • 16
    MS makes some boneheaded decisions. I see the usefulness, if it were optional. – SiXandSeven8ths Nov 16 '17 at 19:41
  • 4
    Seriously? I need to close all apps when I don't want to pop them up again after rebooting? I mean I'm fine with this new default behaviour... but why is there no option :( Maybe there is a way to run scripts before shutdown or reboot, to close all active processes... – Armin Dec 1 '17 at 19:41
  • The worst part is it doesn't even work entirely as described - a good number of apps if left open won't be re-opened at all. – Jeff Dalley Jan 4 at 14:51
  • @JeffDalley: Complain to the developers of these apps. An application needs to use and register to these new feature. how else would it work? The App needs to perform some cleanup work when the computer is shutting down (saving unsaved changes for example and remember which document was opened), so it can restore these after reboot – Tseng Feb 26 at 8:40
  • 1
    I always make sure that I closed everything before shutdown. But sometimes it still tries to open some apps after reboot – notacat Mar 28 at 14:22

I posted this to the MS thread: https://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_perf-insiderplat_pc/programs-autostart-after-boot-in-windows-10-fall/09dd8d3e-7b36-45d1-9181-6587dd5d53ab?messageId=552051d1-b7e5-4709-826a-cce7d243086a

I'll post here too: here is a more friendly solution for someone that doesn't want to have to keep shutting down unwanted apps:

Create a batch file with the following command line:

for /f "tokens=1-3,*" %%a in ('reg query HKCU\Software\Microsoft\Windows\CurrentVersion\RunOnce /v "Application Restart*" ^| findstr "Application Restart"') do reg delete HKCU\Software\Microsoft\Windows\CurrentVersion\RunOnce /v "%%a %%b %%c" /f

Place this somewhere on the drive that the user would have read rights too.

In gpedit.msc, then under User Configuration → Windows Settings → Scripts add the script as a logoff script.

  • 6
    It is pretty common for applications to schedule automatic updates using RunOnce. Will this script prevent such applications from updating, or is it specific to only the apps that were open on shutdown and restart only due to this new 'feature'? – Johannes Nov 8 '17 at 5:28
  • I've tested this batch file approach and can confirm that - as far as I can tell so far - it works as described and is specific to the apps there were open on shutdown. Nice work, thank you. – zippy72 Dec 13 '17 at 10:42
  • clickbangdead, I believe this was an elegant and beautiful solution to the problem, but apparently it no longer works on <version 1709 build 16299.248>. However, using the very same link to the MS thread you provided, a now-working solution can be found on the last pages. I didn't have enough rep to comment at the time, so I posted a solution down below, like an addendum. – Vinícius M Mar 4 at 13:39

The fastest way to reboot without reopening apps I found is: click anywhere on the desktop (or Winkey-D) and then alt-F4 and choose "restart".

  • How did I not know that? Bonus points for finding a quick keyboard shortcut for shutdown / restart for Win 10. – Neil Laslett May 29 at 13:20

I just denied all "write" permission for myself to the registry key HKCU\Software\Microsoft\Windows\CurrentVersion\RunOnce.

Works for me.

  • 1
    This worked for me (y) – user983114 Oct 20 at 20:53

protected by Community Nov 26 '17 at 11:28

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.